[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: XFree86 4.0.2 ATI module/driver

	I have a StarMax 5500/200 running potato and I'm attempting to
get XFree86 4.0.2 to work.  Actually, I'd be fine with 3.3.6 too,
however, the debian install didn't set me up a working solution.
anXious claimed I needed the Mach64 server, which makes sense, given
the Starmax's ATI Rage Pro II card, however, that server was not
installed, leaving me with XF86FBDev.  I don't know a whole lot about
the details of running X on a PPC so I may be missing something

	After compiling and installing X 4.0.2, startx would fail due
to the missing ati driver/module.  I looked around for this module and
[deleted for brevity]
(II) Module scanpci: vendor="The XFree86 Project"
	compiled for 4.0.2, module version = 0.1.0
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(--) PCI: (0:17:0) ATI Mach64 GT rev 154, Mem @ 0x81000000/24,
0xfffff000/12, I/O @ 0x2000/8


(II) ATI: ATI driver (version 6.2.3) for chipsets: ati
(II) R128: Driver for ATI Rage 128 chipsets: ATI Rage 128 RE (PCI),
	ATI Rage 128 RF (AGP), ATI Rage 128 RG (AGP), ATI Rage 128 RK (PCI),
	ATI Rage 128 RL (AGP), ATI Rage 128 Pro PF (AGP),
	ATI Rage 128 Mobility LE (PCI), ATI Rage 128 Mobility LF (AGP),
	ATI Rage 128 Mobility MF (AGP), ATI Rage 128 Mobility ML (AGP)
(II) RADEON: Driver for ATI Radeon chipsets: ATI Radeon QD (AGP),
	ATI Radeon QE (AGP), ATI Radeon QF (AGP), ATI Radeon QG (AGP)
(WW) ATI:  PCI/AGP Mach64 in slot 0:17:0 could not be detected!
(EE) No devices detected.

Have you tried adding
   BusID	"PCI:0:17:0"
to your "Device" section with your ati driver?
I found that for my ibook, even though it _found_ the location, it
was not happy unless you told it the location.  Don't pretend to know


Kin Hoong
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Reply to: