[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: arrow key problem, kernel 2.2.19pre17 -- turn sysrq off



On Sat, Mar 31, 2001 at 09:17:53PM -0800, Matt Brubeck wrote:
> On Sat, 31 Mar 2001, Ethan Benson wrote:
> 
> >> After upgrading to kernel-image-2.2.19pre17-pmac, I can no longer use
> >> my right arrow key. It is not sending any key events at all, according
> >> to xev and showkey. The keys worked fine under a 2.2.18 kernel I
> >> compiled myself from kernel.org sources.
> 
> > i vaguely remember benh grumbling about this on irc a couple weeks
> > ago, iirc he finally figured out that the kernel decided that the
> > arrow key should be sysrq or something silly like that.  is sysrq
> > turned on in this kernel?
> 
> $ grep SYSRQ /boot/config-2.2.19pre17
> CONFIG_MAGIC_SYSRQ=y
> 
> That would explain why my other kernel worked -- sysrq was off in that.

yup, compile a kernel without it, that should fix it.  sysrq has a
tendency to be broken on powerpc since none of the powerpc kernel
hackers seem to use it.  

ugh, in fact this should probably be turned off for pmac before potato
r3, otherwise we are in for another 6 months of endless questions on
this list `why doesn't the arrow key work!!'  

-- 
Ethan Benson
http://www.alaska.net/~erbenson/

Attachment: pgpfPvRRte1Y4.pgp
Description: PGP signature


Reply to: