[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ATA booting problems & solutions

:::: Prior to now, Ethan Benson wrote :::::::

I'm convinced that quik succeeded in putting the bootblock on /dev/hdb2,
(or at least I'm going to pretend to be for now) so I'm going about trying
to boot from that partition.

Problem 1:	"ofpath" doesn't work on my system
Problem 2:	The hdb thing worries me because I know the thing is
		set to be master but it's not coming up as hda.

Barring those,

I know that "ata/ATA-Disk" is a valid OF device because I can look
at its properties. Also, it says it "can't LOAD from" the device,
which leads me to think it's finding a partition, but can't grok

	is /dev/hdb2	==	ata/ATA-Disk@0:0
	is /dev/hdb2	==	ata/ATA-Disk@0:1


	is /dev/hdb2	==	ata/ATA-Disk@0:2 ?

Maybe I need those patches...
Maybe I should just go try to find a MacOS disk...

I've just been trying to improve my mac-fu.

:: i have not seen such a OF device path before...  try ofpath /dev/hdb
:: to get an idea what the device path is.  for boot-device this will
:: work (assuming ofpath /dev/hdb worked):
:: nvsetenv boot-device "$(ofpath /dev/hdb)0"
:: or
:: nvsetenv boot-device "$(ofpath /dev/hdb3)"
:: on some oldworlds you need to change the load-base and other
:: variables, im not sure what and which, the netbsd FAQ is helpful
:: here.  (don't have the url handy)
:: > 	    I've seen a comma in the device tree, but I wonder if that's
:: > 	    not a red herring. It seems clear that it's supposed to be
:: > 	    x=unit and z=partition number. Is partition 0 the same as the
:: > 	    first partition after the partition map? That makes /dev/hdb2
:: > 	    come out to "ata/ATA-Disk@1:0". That's not working for me.
:: what i have usually seen is something like ata/disk@1:0  
:: you may also need OF patches to make OF read the disk properly.  
:: > Detail:
:: > 
:: > I have a powerbase 160 and would love to get Linux on it without having to
:: > find a CD-ROM of MacOS that will work with it. They're getting pretty rare.
:: it can be done, its just a tad tricky. 
:: > Secondly, I've tried creating an Apple_Bootstrap partition for yaboot and
:: > a quik bootblock header on my root filesystem, but still don't seem to be
:: > able to boot into the OS without the install system.
:: don't even try to boot yaboot, just leave the bootstrap partition
:: alone just in case you move the disk to a newworld box.  for now
:: ignore it.  
:: > I've tried a variety of boot-device setting, including the obvious choices:
:: > 
:: > ata/ATA-Disk@0:0 (For some reason I thought that this might boot the first
:: >                   bootable partition)
:: yes partition 0 should find the bootable partition.  
:: > ata/ATA-Disk@0:2 (since the root partition is on /dev/hdb2)
:: > ata/ATA-Disk@0:8 (since the yaboot bootstrap partition is on /dev/hdb8)
:: don't bother here, ignore the bootstrap partition oldworld OF cannot
:: use it.  
:: > ata/ATA-Disk@1:2 (since it's /dev/hdb2 and not /dev/hdba2 -- who knows)
:: > ata/ATA-Disk@1:8 ("                                                  ")
:: > 	(responds with: "DEFAULT CATCH!, code=FFF00300 at   %SRR0: FF80BFD8   %SRR1: 00008070")
:: > 	(I assume this means there's no drive there.)
:: if you booted via auto-boot it could mean the disk was not spun up
:: when OF tried to read from it, Oldworlds did not boot via OF, OF just
:: kicked in the MacOSROM which had its own methods for reading the
:: disk. thus apple did not bother to make OF read disks correctly.
:: there is a small forth script to use as the boot-command around that
:: adds a delay to fix this.  otherwise it probably means some variables
:: need to be changed, such as load-base.  you also might need OF patches
:: but i don't know if any of apple's patches work on this machine. 
:: -- 
:: Ethan Benson
:: http://www.alaska.net/~erbenson/

:::: End inclusion from Ethan Benson :::::::

	"We can dump hot oil on your cybernetic head."
						-- Forrest Swilling

Reply to: