[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unidentified subject!

Renaud Dreyer <rdreyer@math.berkeley.edu> writes:

> > Abologies to Yann since I cc'ed 2 bugs with this, but I think it should be in 
> > the discussion of both.
> > 
> > While this bug *is* resolved in 1999.08.29-9 for me the prerm script in 
> > 1999.08.29-8 (the one that actually broke on my machine) fails, so the new one 
> > does not get installed. In my case, the solution was to obtain the actual deb 
> > (should be in /var/cache/apt/archives/console-data_1999.08.29-9_all.deb if apt 
> > just failed) and dpkg -i --force confnew console-data_1999.08.29-9.deb. That 
> > made the install succeed. I don't know if there is any way to make this 
> > automatically use the new scripts, but it would help.
> Unfortunately this didn't work for me, I still get the same error. I also
> have a "/proc/hardware not found" error by the way. Thanks,

i don't have a /proc/hardware either. what i did is edited
/var/lib/dpkg/info/console-data.config and added my architecture by

    if (($arch eq 'powerpc') || ($arch eq 'm68k')) {
#	my $subarch = lc substr (`grep ^Model: /proc/hardware`, 7);
#	$subarch =~ s/^macintosh$/mac/;
#	$subarch =~ s/^motorola$/mvme/;
#	$subarch =~ s/^powermac|powerbook*|power|imac*|powermac1*$/pmac/;

#	$arch = "$arch/$subarch";
        $arch = "powerpc/pmac";        <-- add the corresponding arch

this is line 359. not elegant but i finally got console-data
configured. (after making the changes run dpkg --configure


| I believe the moment is at hand when, by a paranoiac and active |
|  advance of the mind, it will be possible (simultaneously with  |
|  automatism and other passive states) to systematize confusion  |
|  and thus to help to discredit completely the world of reality. |

Reply to: