[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Anacron and xcdroast problem report

On Thu, 9 Sep 1999, Frank Petzold wrote:

> I installed the latest anacron package yesterday, but the executable hangs on 
> my machine. I even tried recompiling, but with the same result. Does anyone 
> have a running anacron?

No, this is a none bug in the BTS.  It appears to be an arch-specific
problem.  Here's a strace on "anacron -s":

[Early stuff omitted]
open("/lib/libc.so.6", O_RDONLY)        = 3
fstat(3, {st_mode=0200000, st_size=936893318, ...}) = 0
read(3, "\177ELF\1\2\1\0\0\0\0\0\0\0\0\0\0"..., 4096) = 4096
mmap(ptrace: umoven: Input/output error
)                                  = 0x30017000
mmap(ptrace: umoven: Input/output error
)                                  = 0x16b9000
mprotect(0x1799000, 356048, PROT_NONE)  = 0
mmap(0x645f7265, 1903519091, PROT_READ|PROT_EXEC|0x74006460, 0xc /*
1952409193, 0x6c655f6e) =
mmap(0, 0, PROT_NONE, MAP_FILE, 0, 0)   = 0x17ec000
close(3)                                = 0
munmap(0x30014000, 10788)               = 0
getpid()                                = 17463
brk(0)                                  = 0x18458d8
brk(0x1845a78)                          = 0x1845a78
brk(0)                                  = 0x1845a78
brk(0x1846000)                          = 0x1846000
getpid()                                = 17463
[Hanging here]

I haven't looked beyond this yet, though...there are bigger fires...

> Xcdroast is not capable of writing the images it creates. When hitting the 
> "Write" button, I get an error message from cdrecord-1.6.1 (which is located 
> in /usr/lib/xcdroast...) about an invalid option.

Can't comment on this one, but I want to point out that we probably have
hundreds of PPC-specific bugs in our already built packages.  I just found
an endianess problem in ext2resize the other day.  That's why we need to
get boot-floppies stable for all subarchs so we can get more PowerPC

Matt Porter                                   Motorola Computer Group
mporter@mcg.mot.com                           CIBU Linux Support

Reply to: