[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian PowerPC/Joys & Woes

>>>>> "C" == C M Connelly <c@eskimo.com> writes:

    C> Hi,

    C> First, some good news. We have Debian GNU/Linux running on our
    C> PowerCenter 132, with X, GNOME, MH, sendmail, etc. all
    C> installed. It's great to be running Linux on this system --

That's awesome.  I got Debian up on my B&W G3 a couple months ago, and I
haven't gone back to MacOS. :)

    C> But the installation was far from easy, documentation seems to
    C> be hard to come by, and system still feels too flaky to really
    C> trust.

    C> The Install -----------

    C> After installing LinuxPPC R5, and not being very happy with the
    C> result, we decided to try Debian, despite the ``unstable''
    C> status of the potato release.  We spent several hours reading
    C> Web pages, USENET posts, and mailing list archives and decided
    C> that the way to install Debian/PowerPC appeared to be as
    C> follows (from the Linux on PowerPC FAQ-O-Matic,
    C> <http://www.dartmouth.edu/~jonh/lppc-serve/cache/572.html>):

    C>    1. Obtain all necessary packages.

    C>    2. Create and format partitions for root, /usr, and so
    C> forth.

    C>    3. From a LinuxPPC install, untar the base2_2.tgz file and
    C> run chroot to switch into running the Debian system.

    C>    4. Run dselect to configure unconfigured packages.

    C>    5. Quit back into LinuxPPC.

    C>    6. Edit various configuration files.

    C>    7. Reboot into Debian.

    C>    8. Use dpkg/dselect to install packages.

    C> Our first problem occurred at step 7.  We couldn't boot into
    C> Debian because the base2_2 filesystem assumes that you only
    C> have two SCSI disks on your system (sda and sdb).  Since this
    C> machine has three SCSI hard disks, and all the Linux partitions
    C> are on the third (sdc), we had to copy device files from the
    C> LinuxPPC system to get things working.

Are you aware that there are installer ``disks'' for PowerPC now?  I haven't
used them (my machine isn't supported with them), but they appear to work.

    C> Once the device files were in place, we could reboot into
    C> Debian.  The initial configuration script ran fine, but the
    C> last part of the script -- where you're supposed to be able to
    C> choose from sets of predefined packages based on the role of
    C> the system -- failed, because the data file for this step
    C> contained no useful information (perhaps it was a placeholder
    C> file?).
    C> So we decided to install packages by hand, using dselect and/or
    C> dpkg.  Since our 'Net connection is slow, we opted to use
    C> packages from CD-ROMs burned from the then current distribution

Yikes, that's an experience.  They way I did the installation was the

    1) Boot into the LinuxPPC installer disks, and get a boot prompt
      (after getting the second stage installer up).

    2) Create the required partitions using pdisk, formatted them, and
       mounted them in the arrangement that I wanted.

    3) Mounted (through NFS) the untarred base2_2.tgz file.

    4) Copied the contents of the NFS mount to the local disk.

    5) Unmounted the local harddrive, and rebooted.

    6) Booted Debian in single user mode.

    7) Created the fstab, updated all the init scripts, and did some more
       general cleanup of the base filesystem (like the removal of the
       ``unconfigured'' in ``/usr/bin'', or whereever it was).

    8) Rebooted, and started at runlevel 2.

    9) Ran dselect as root, and installed everything.

    10) Went to Carl's Junior, and get 2 Santa Fe Chicken Sandwiches, ate

    11) Configured the packages.

    12) Grabbed a copy of an XF86Config for the fbdev X server.

    13) Ran X.

    14) Brought up XEmacs.

    15) Sent so mail.

    16) Done.

    C> Once we had most of the packages in place, the system worked,
    C> more or less, except for X.

    C> We discovered that the 2.2.9 and 2.2.10 kernels provided in
    C> Debian packages didn't support our machine very well.  Most

Yeah, I've had better luck w/ running older kernels that were configured
for my box.  I've had file corruption problems w/ the latest 2.2.x kernels.

    C> important, the video driver for the Platinum video in our
    C> machine was badly broken, and did not work well enough to start
    C> X.  We initially solved the problem by copying Xpmac from the
    C> LinuxPPC distribution and booting using the No Video Driver
    C> option in BootX. Eventually, we found down a patched version of
    C> the 2.2.10 kernel source from the vger CVS archive that
    C> included fixes for the Platinum video driver (among other

Welcome to Linux. ;)

    C> things). Once we had a working kernel video driver, we could
    C> run XF68_FBDev, although figuring out a proper XF86Config was
    C> `interesting', since there wasn't much useful documentation --
    C> the XF86 documentation doesn't really apply to XF68_FBDev.

Yeah, that's a real problem.  


    C> Rough Edges -----------

    C> There are still a number of problems, including various nasty
    C> errors with Emacs and XEmacs (there are errors such as
    C> ``Arithmetic range error: "truncate", 238608659.55555555'' that
    C> show up at various times when opening files, attempting to run
    C> the customization routines, etc., as well as dumping core when
    C> run in a terminal), various GTK applications (ranging from one

Hmm.. I haven't seen this.

    C> or two error messages to hundreds), Window Maker (touching the
    C> clip is a sure way of crashing the window server), sound, and
    C> so on.  Perl is still hit and miss, as well -- some modules and

The latest Window Maker out of Potato has been rock solid for me.

    C> libraries are present, some aren't (and, as a result, lots of
    C> applications that depend on Perl fail in various ways).

    C> We are also unable to use the apt-get command -- with or
    C> without socksify, it attempts to connect to
    C> http://http.us.debian.org and fails.

You might try going for an older kernel.  I haven't been impressed w/ the
stability of the latest 2.2.x kernels... this might fix a number of
your problems.


    C> Lingering Questions -------------------

    C> We're left wondering the following:

    C>   - What can we do to help make things better?

Become a Debian developer (although I'm not one yet, I'm waiting for them
to acknowledge my application).

    C>     We're happy to put in some time, writing documentation,
    C> tracking down problems and submitting bug reports. But it's
    C> very hard to know where to begin -- is a given problem
    C> something wrong with the application, with the kqernel, with
    C> the libraries we have installed, or due to some other aspect of
    C> our installation?  (As a case in point, emacs dumps core when
    C> it quits if it isn't using X (e.g., ``emacs -nw --help''
    C> triggers the bug); it actually dies inside chunk_free in the C
    C> library; but whether the culprit is emacs, libc or a broken
    C> Debian installation is unclear.)

Definitely try downgrading your kernel.

    C>   - Where are the people who have Debian running on PowerPC
    C> machines, who understand what's going on, how development is
    C> progressing and so on, hanging out?  Are they documenting
    C> things?  And where is that documentation?

Nobody here but us chickens. =]

    C>     For example, we *know* that some people somewhere must
    C> actually use the vger CVS kernel source repository, yet it is
    C> not at all easy for the uninitiated to figure out the command
    C> necessary to check out the source tree.  The documentation on
    C> the cvs.on.openprojects.net web site would have you believe the
    C> command is `cvs -z3 checkout kernel', which doesn't work.  If
    C> you guess that you could type `cvs -z3 checkout linux', you end
    C> up with a bleeding edge 2.3.x kernel rather than a stable
    C> series kernel.

Hrm, but that's the way it should be, you run a ``cvs checkout'', and it
will grab the the head of the mainline branch.  That's how CVS works.
I'm not sure of any tags in that CVS repository that will check out
a more stable kernel, I haven't looked in a while.

    C>     It turns out that the commands to get the latest 2.2.x
    C> kernel from the vger repository are:


    C>     We discovered the correct incantation by chancing on an FTP
    C> site with a checked-out copy of the 2.2.x branch and examining
    C> the Repository, Root and Tag files in the CVS directory.

Yup, that sounds about right

    C>   - Is there a better way to install the system that would
    C> install all the necessary packages, including ones we might not
    C> think about?  If so, should we reinstall the system?

I'm not sure what the status of the installer is for your system, you might
try using that, but don't take my word for it (as I said, it doesn't work
on my machine).

    C>   - What are the correct settings necessary to use apt-get in
    C> order to even find out about updated packages?

It ``just worked'' for me, but that might be because my installation is
different than yours.

    C>   - Should we be submitting formal bug reports for everything
    C> that doesn't work?  (We don't want to nag at people if all of
    C> these things are known problems.)

You should probably post asking about it, maybe you'll get discussion going
Re: the problem.

    C>   - Is there some secret storehouse of documentation we just
    C> aren't seeing?

Yup, but unless you can read the minds of the Debian developers, it would
be hard to access. =]

Honestly, the documentation is lacking.  One reason being there are
so many variations of PowerPC hardware.


Reply to: