[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Failed base upgrade to bash 2.02

When I upgraded all of my base packages, bash broke.  libc6 went from
2.1->2.1.1 and the current bash binary is dependent on 2.1.  It segfaulted
with the new library when attempting to run the bash.prerm script.
Extracting the new bash binary allowed me to complete the exercise.

Seems like bash 2.01 should have depended specifically on libc6 2.1.

Matt Porter
This is Linux Country. On a quiet night, you can hear Windows reboot.

Reply to: