[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[robert@plukwa.pdi.net: gmp2 debian (?) package]

 Originaly i've sent this message to ML about Linux PPC for PowerPC accel
cards for Amiga. I'm using Amiga 1200 with BlizzardPPC 603e+ turbo card
 Thanks for any comments

----- Forwarded message from Robert Ramiega <robert@plukwa.pdi.net> -----

Date: Thu, 4 Feb 1999 22:34:34 +0100
From: Robert Ramiega <robert@plukwa.pdi.net>
To: linux-apus@sunsite.auc.dk
Subject: gmp2 debian (?) package
X-Mailer: Mutt 0.94.12i

 So after hard fight i have my Amiga running Debian GNU/Linux =o))
 Now to the subject:
 In my work i need to have working ssh. ssh need gmp2 package (i believe it's
the same on RH also). I'v got gmp2_2.0.2-6_powerpc.deb from Polish mirror
(ftp.task.gda.pl). It installed ok. After that i tried to install
ssh-1.2.26-1.2 (this one was dl'ed either from ftp.task.gda.pl or
sunsite.doc.ic.ac.uk). Install failed because of unresolved symbol in
libgmp2.so.2 (this symbol was mpn_add_n). At first i blamed this to upgrade 
of libc6 but soon i realised that it's gmp2 fault. I downloaded binary
package and tried to recompile. This also failed. 
 The problem was syntax in asm files in gmp2-2.0.2/mpn/powerpc32. As i don;t
know assembler i took C files from generic and i got working gmp2 package.
 I don't know if it is deb fault (badly created) or is this gmp2 fault (this
might as well be some incomatibility in egcs/binutils) What i'm asking is
this: could someone try installing gmp2 and ssh on RH and see if it works ?
(if it's gmp2 it'll fail during generation of server ssh-key). Also someone
else with Debian could try this? 
 I don't have the time now to inspect gmp to see if it would behave any
different on 604 (there is subdir gmp2-2.0.2/mpn/powerpc64 with quite
different contents)


----- End forwarded message -----

 Robert Ramiega   | robert@pdi.net    IRC: _Jedi_ | Don't underestimate 
 IT Manager @ PDi | http://plukwa.pdi.net/        | the power of Source

Reply to: