[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Support for cfdisk for Linux-PowerPC

>>>>> "Andries" == Andries Brouwer <Andries.Brouwer@cwi.nl> writes:

Andries>  I have alreday got a lot of patches for powerpc.
Andries> ...
Andries> I'll try to make util-linux-2.9f within a week. No promises.

Andries> See ftp.win.tue.nl

I tried it  => congratulation works fine. I even noticed you added the 0x41
partition type. This is very kind. I now have cfdisk able to work on 

	  - RH4 for powerpc,
	  - Debian slink (aka 2.1) for powerpc,

Please note that this may highly interest debian people who have no
working cfdisk yet. I tested the logical partitions : they work great as 
shown below.

[root@ppc1target byteorder]# uname -a
Linux ppc1target.crf.canon.fr 2.1.129 #105 Mon Dec 7 11:41:28 CET 1998 ppc unknown

[root@ppc1target byteorder]# dmesg |grep sda
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
SCSI device sda: hdwr sector= 512 bytes. Sectors= 8388315 [4095 MB] [4.1 GB]
 sda: sda1 sda2 sda3 sda4 < sda5 sda6 >

I still need to test what happens on a disk partitionned directly on MAC OS.
I tried cfdisk on machines where I used a ramdisk and created everything by 
hand as they are motorola board (mcp750) and not regular Mac. As I now have 
a regular Power mac DT 300 running debian slink, I will test it soon. 

Just a minor remark : you have many error message like that
/usr/include/asm/bitops.h:240: warning: implicit declaration of function `cpu_to_le32p'

It could be cleared by adding 

#ifdef __linux__
#include <asm/byteorder.h>

at the relevant place...

  /  `                   	Eric Valette
 /--   __  o _.          	Canon CRF
(___, / (_(_(__         	Rue de la touche lambert
				35517 Cesson-Sevigne  Cedex
Tel: +33 (0)2 99 87 68 91	Fax: +33 (0)2 99 84 11 30
E-mail: valette@crf.canon.fr

Reply to: