[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrade to GLIBC_2.1

On Sat, Dec 12, 1998 at 01:13:16PM -0500, cfm@maine.com wrote:
> re upgrade to GLIBC_2.1
> I just ran apt-get upgrade on my powerpc and it died
> with this error:
> dpkg: error in loading shared libraries: dpkg: symbol chown, version
> GLIBC_2.1 not defined in file libc.so.6 with link time reference
> Given that the system is currently running and that it is a PITA
> to bring it up from scratch I'm hesitant simply to force this
> upgrade through.
> Can anyone suggest an approach?

You've got the wrong libc6 package installed, apparently.  This needs a
versioned dependency apparently...

Get libc6_2.0.100-*.deb.  You may be able to extract it with:
cd / && ar x /tmp/libc6*.deb data.tar.gz && tar xzf data.tar.gz

On the other hand, that may fail.  Your best path may be to untar it on
a remote machine and use ftp to get the file.


/--------------------------------\  /--------------------------------\
|       Daniel Jacobowitz        |__|     CMU, CS class of 2002      |
|   Debian GNU/Linux Developer    __   Part-Time Systems Programmer  |
|         dan@debian.org         |  |        drow@cs.cmu.edu         |
\--------------------------------/  \--------------------------------/

Reply to: