[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#568313: Suggestion: forbid the use of dpkg-statoverride in postinst scripts, except for --list

On Thu, 04 Feb 2010, martin f krafft wrote:
> I can perfectly understand admins wanting to override package
> defaults, but not why the package maintainer needs to use
> dpkg-statoverride.

You need to use dpkg-statoverride when you are using a dynamic uid/gid
and files that you ship need to be setuid/setgid to that uid/gid, or
when you've got a sensible default of not setgid (or similar) but you
want that setting to be easily configurable via debconf.

Don Armstrong

"There's no problem so large it can't be solved by killing the user
off, deleting their files, closing their account and reporting their
REAL earnings to the IRS."
 -- The B.O.F.H..

http://www.donarmstrong.com              http://rzlab.ucr.edu

Reply to: