[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#83669: Shared libraries

>>>>> "Ben" == Ben Collins <bcollins@debian.org> writes:

    Ben> So? This makes things consistent, and much easier to track
    Ben> bugs and problems. Your proposal would make things really
    Ben> difficult to track bugs "The bug only shows up when I have
    Ben> libfoo1_1.0 and libfoo-dev_0.9 installed". This puts too much
    Ben> load on the maintainer.

If done properly, the maintainer only need to know if the user is
trying to compile an application (libfoo-dev is used) or trying to run
an application (libfoo1 is used).

Might be confusing the package a is compiled based on an older version
of libfoo-dev, but executed with the newer version of libfoo1,
but still it should be easy to realize what is happening (just stick
to the previous rule).

*.la files will be a problem, as explained in my other message.
Brian May <bam@debian.org>

Reply to: