[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#83669: Shared libraries

Marcelo E. Magallon <mmagallo@debian.org> wrote:
>  I don't think I understand what you mean by manage here.  You can't
>  prevent users from running 'ldconfig'.  If you run 'ldconfig' it will
>  read the sonames and place symlinks to the "newer versions" of the
>  library.  

If you've got both foo 2.0 and foo 2.1 installed, ldconfig will symlink
foo 2.1 it to foo.so.2 which is exactly what you want.
Debian GNU/Linux 2.2 is out! ( http://www.debian.org/ )
Email:  Herbert Xu ~{PmV>HI~} <herbert@gondor.apana.org.au>
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt

Reply to: