[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#53700: marked as done (bogosity in editor/pager discussion)



Your message dated Thu, 18 Jan 2001 14:47:32 -0500
with message-id <E14JL1w-0006sr-00@auric.debian.org>
and subject line Bug#53700: fixed in debian-policy 3.2.1.2
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Darren Benham
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 29 Dec 1999 19:40:47 +0000
Received: (qmail 28769 invoked from network); 29 Dec 1999 19:40:40 -0000
Received: from ursa.cus.cam.ac.uk (cusexim@131.111.8.6)
  by master.debian.org with SMTP; 29 Dec 1999 19:40:40 -0000
Received: from bjh21 (helo=localhost)
	by ursa.cus.cam.ac.uk with local-smtp (Exim 3.12 #1)
	id 123Oxa-0007OY-00
	for submit@bugs.debian.org; Wed, 29 Dec 1999 19:40:38 +0000
Date: Wed, 29 Dec 1999 19:40:37 +0000 (GMT)
From: Ben Harris <bjh21@cam.ac.uk>
To: submit@bugs.debian.org
Subject: bogosity in editor/pager discussion
Message-ID: <Pine.SOL.3.96.991229193448.28349A-100000@ursa.cus.cam.ac.uk>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII
Sender: Ben Harris <bjh21@cus.cam.ac.uk>

Package: debian-policy
Version: 3.1.1.1

Section 5.4 of Policy says:

> Since the Debian base system already provides an editor and a pager
> program, there is no need for a package to depend on `editor' and
> `pager', nor is it necessary for a package to provide such virtual
> packages.

I believe that this reasoning is incorrect.  Just because a package is in
the base system, it doesn't mean it need not be depended upon.  The author
seems to have confused "base" and "Essential" (on which I believe
dependencies are un-necessary).  I feel that the correct fix for this is
to add new virtual packages for "editor" and "pager", but that'd be a lot
of work, so just removing the justification from that sentence might be
better.

-- 
Ben Harris
Unix Support, University of Cambridge Computing Service.
E-mail: bjh21@cam.ac.uk  Tel: +44 (0)1223 334728  Fax: +44 (0)1223 334679

---------------------------------------
Received: (at 53700-close) by bugs.debian.org; 18 Jan 2001 22:19:41 +0000
>From troup@auric.debian.org Thu Jan 18 16:19:40 2001
Return-path: <troup@auric.debian.org>
Received: from murphy.debian.org [::ffff:216.234.231.6] 
	by master.debian.org with smtp (Exim 3.12 1 (Debian))
	id 14JNP9-0001Wf-00; Thu, 18 Jan 2001 16:19:39 -0600
Received: (qmail 898 invoked from network); 18 Jan 2001 19:48:48 -0000
Received: from auric.debian.org (mail@206.246.226.45)
  by murphy.debian.org with SMTP; 18 Jan 2001 19:48:48 -0000
Received: from troup by auric.debian.org with local (Exim 3.12 1 (Debian))
	id 14JL1w-0006sr-00; Thu, 18 Jan 2001 14:47:32 -0500
From: Debian Policy List <debian-policy@lists.debian.org>
To: 53700-close@bugs.debian.org
Subject: Bug#53700: fixed in debian-policy 3.2.1.2
Message-Id: <E14JL1w-0006sr-00@auric.debian.org>
Sender: James Troup <troup@auric.debian.org>
Date: Thu, 18 Jan 2001 14:47:32 -0500
Delivered-To: 53700-close@bugs.debian.org

We believe that the bug you reported is fixed in the latest version of
debian-policy, which has been installed in the Debian FTP archive:

debian-policy_3.2.1.2.dsc
  to pool/main/d/debian-policy/debian-policy_3.2.1.2.dsc
debian-policy_3.2.1.2_all.deb
  to pool/main/d/debian-policy/debian-policy_3.2.1.2_all.deb
policy.text.gz byhand
policy.html.tar.gz byhand
menu-policy.text.gz byhand
debian-policy_3.2.1.2.tar.gz
  to pool/main/d/debian-policy/debian-policy_3.2.1.2.tar.gz
virtual-package-names-list.text byhand
mime-policy.text.gz byhand
policy.ps.gz byhand
policy.pdf.gz byhand
libc6-migration.text byhand
A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 53700@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Debian Policy List <debian-policy@lists.debian.org> (supplier of updated debian-policy package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----

Format: 1.7
Date: Thu, 18 Jan 2001 01:43:58 -0600
Source: debian-policy
Binary: debian-policy
Architecture: source all
Version: 3.2.1.2
Distribution: unstable
Urgency: low
Maintainer: Debian Policy List <debian-policy@lists.debian.org>
Changed-By: Manoj Srivastava <srivasta@debian.org>
Description: 
 debian-policy - Debian Policy Manual and related documents
Closes: 51879 53496 53700 55048 55730 57154 59403 65765 66912 76028
Changes: 
 debian-policy (3.2.1.2) unstable; urgency=low
 .
   * The minimal change in version number is so that people can test and
     root out the bugs in this document before we make everyone change to
     this version.
   * Document the Enhances relationship
   * Removed the restriction that one, and exactly one, person must
     maintain a package.                            closes: Bug#51879
   * Fixed a typo, and added the nogroup name, in uid/gid section of
     policy.                                        closes: Bug#53496
   * Fixed a misstatement in policy about not needing to depend on packages
     in the base system (not true -- the Essential tag is significant)
                                                    closes: Bug#53700
   * Clarified update-rc.d stuff                    closes: Bug#55048
 .
   * We have already included the material for shlibdep changes, and most
     of this is not relevant to policy anyway.      closes: Bug#55730
   * makedev--> MAKEDEV                             closes: Bug#57154
   * Added restrictions on the files in /usr/share/doc/
                                                    closes: Bug#59403
   * Changed location of a paragraph about copyright files into the section
     that deals with copyright files.               closes: Bug#65765
   * init script configuration variables            closes: Bug#66912
   * Clarifed language about packages sharing a conffile need to be marked
     as conflicting                                 closes: Bug#76028
Files: 
 7873b3a6ddd5f3fc015ccb2aaae800a8 662 doc optional debian-policy_3.2.1.2.dsc
 9cbc8f71b1bb280c441a9e33cc85daa5 486560 doc optional debian-policy_3.2.1.2.tar.gz
 04d4f5d13f7ab04c97034c884e6425b4 542540 doc optional debian-policy_3.2.1.2_all.deb
 42928cef99fee859b6442277e91eeb22 120715 byhand - policy.ps.gz
 9632447891b3a57f956b52c80fd177e7 208362 byhand - policy.pdf.gz
 0fbf6fcc843ed1c928f5f92b05949c43 66419 byhand - policy.html.tar.gz
 203f852c33bd0d6df7b8a66977728d98 62122 byhand - policy.text.gz
 3ed7aa5a489834b24bb28ff377a34aa9 10982 byhand - libc6-migration.text
 1e4917c791262f0cd6de796444e51c86 7785 byhand - virtual-package-names-list.text
 1b08168ee1c506d3475612bc4d3cdbbf 2180 byhand - menu-policy.text.gz
 52f844690780aef153828e7325e90d91 1599 byhand - mime-policy.text.gz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.4 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE6ZqAGIbrau78kQkwRAdekAKDV1PGCUax5rPPt54LgMtGzQA5odACdH0xE
RX5CFc75JTHxEfEmaPEfUPk=
=+KRS
-----END PGP SIGNATURE-----



Reply to: