[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#745772: ITP: libdigest-perl-md5-perl -- Perl Implementation of Rivest's MD5 algorithm

Package: wnpp
Owner: Florian Schlichting <fsfs@debian.org>
Severity: wishlist
X-Debbugs-CC: debian-devel@lists.debian.org,debian-perl@lists.debian.org

* Package name    : libdigest-perl-md5-perl
  Version         : 1.9
  Upstream Author : Christian Lackas <delta@lackas.net>
* URL             : https://metacpan.org/release/Digest-Perl-MD5
* License         : Artistic or GPL-1+
  Programming Lang: Perl
  Description     : Perl Implementation of Rivest's MD5 algorithm

Digest::Perl::MD5s has the same interface as the much faster Digest::MD5, but
unlike that, it is not an interface but a Perl implementation of MD5. Because
of this it is slow but it works without C-Code. You should use Digest::MD5
instead of this module if it is available. This module is only useful for

 - computers where you cannot install Digest::MD5 (e.g. lack of a C-Compiler)
 - encrypting only small amounts of data (less than one million bytes),
   e.g. hashing passwords.
 - educational purposes

libdigest-perl-md5-perl is a dependency of libspreadsheet-parseexcel-perl,
which uses its internal state in its decryption routines and hence cannot be
switched to use Digest::MD5 instead. It will be maintained by pkg-perl.

Reply to: