[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#735076: otrs2: please add (build-)dependency on libxml-parser-lite-perl

Package: otrs2
Version: 3.3.3-2
Severity: important
Tags: patch


There is a new release of SOAP-Lite (libsoap-lite-perl) that we are preparing, 
and it no longer inclides XML::Parser::Lite. That was given separate life and 
is now available as libxml-parser-lite-perl package in Debian.

Since otrs2 seems to use XML::Parser::Lite, the new release of 
libsoap-lite-perl will break otrs2, which now needs to depend on the separate 
libxml-parser-lite-perl package.

We are delaying the upload to avoid surprise-breaking otrs2, but we would like 
to upload soon, and would appreciate a quick adjustment of otrs2. I could NMU 
too if you like.

    Debian Perl Group
diff --git a/debian/changelog b/debian/changelog
index 8d8980b..e9d4d12 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+otrs2 (3.3.3-2.1) UNRELEASED; urgency=medium
+  * Non-maintainer upload.
+  * add dependency on libxml-parser-lite-perl, split off libsoap-lite-perl
+ -- Damyan Ivanov <dmn@debian.org>  Sun, 12 Jan 2014 17:24:55 +0200
 otrs2 (3.3.3-2) unstable; urgency=high
   * Add missing ivory-slim/css-cache directory.
diff --git a/debian/control b/debian/control
index 197d2d9..20f4b6c 100644
--- a/debian/control
+++ b/debian/control
@@ -28,6 +28,7 @@ Depends: ${misc:Depends},
  dbconfig-common (>= 1.8.24),
+ libxml-parser-lite-perl,

Reply to: