[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Cannot receive snmp traps on opsview slave server



Hello, 

I've installed an opsview-slave on debian lenny and it works great! (http://docs.opsview.org/doku.php?id=opsview3.3:slavesetup)
The only problem I've got, is receiving SNMP traps. On the check "SNMP Trap - Alert on any trap" I'm getting the message "Service is not scheduled to be checked...". 

I've executed the following command on the slave-server: cat testtrap | /usr/local/nagios/bin/snmptrap2nagios -d -e /tmp/snmptrap.exception
The testtrap file contains the following text:
##############################
10.0.0.4
10.0.0.4
SNMPv2-MIB::sysUpTime.0 4:20:49:47.73
SNMPv2-MIB::snmpTrapOID.0 SNMPv2-SMI::enterprises.9.9.43.2.0.1
SNMPv2-SMI::enterprises.9.9.43.1.1.6.1.3.45 1
SNMPv2-SMI::enterprises.9.9.43.1.1.6.1.4.45 2
SNMPv2-SMI::enterprises.9.9.43.1.1.6.1.5.45 3
SNMP-COMMUNITY-MIB::snmpTrapAddress.0 10.0.0.4
SNMP-COMMUNITY-MIB::snmpTrapCommunity.0 "mycommunity"
################################

And I received the following error message:
################################
Can't load '/usr/local/nagios/perl/lib/i486-linux-gnu-thread-multi/auto/Time/HiRes/HiRes.so' for module Time::HiRes: /lib/i686/nosegneg/librt.so.1: symbol __pthread_clock_gettime, version GLIBC_PRIVATE not defined in file libpthread.so.0 with link time reference at /usr/lib/perl/5.10/DynaLoader.pm line 196.
at /usr/local/nagios/perl/lib/Log/Log4perl/Layout/PatternLayout.pm line 32
Compilation failed in require at /usr/local/nagios/perl/lib/Log/Log4perl/Layout/PatternLayout.pm line 32.
BEGIN failed--compilation aborted at /usr/local/nagios/perl/lib/Log/Log4perl/Layout/PatternLayout.pm line 45.
Compilation failed in require at /usr/local/nagios/perl/lib/Log/Log4perl/Layout.pm line 5.
BEGIN failed--compilation aborted at /usr/local/nagios/perl/lib/Log/Log4perl/Layout.pm line 5.
Compilation failed in require at /usr/local/nagios/perl/lib/Log/Log4perl/Logger.pm line 11.
BEGIN failed--compilation aborted at /usr/local/nagios/perl/lib/Log/Log4perl/Logger.pm line 11.
Compilation failed in require at /usr/local/nagios/perl/lib/Log/Log4perl.pm line 12.
BEGIN failed--compilation aborted at /usr/local/nagios/perl/lib/Log/Log4perl.pm line 12.
Compilation failed in require at /usr/local/nagios/bin/snmptrap2nagios line 43.
BEGIN failed--compilation aborted at /usr/local/nagios/bin/snmptrap2nagios line 43.
Undefined subroutine &Log::Log4perl::Logger::cleanup called at /usr/local/nagios/perl/lib/Log/Log4perl.pm line 5.
END failed--call queue aborted at /usr/local/nagios/bin/snmptrap2nagios line 43.
################################

On the opsview website i asked for help. But they said that the binary linking of the library modules is at fault. So its a bug in the OS.

Can someone help me with this problem? If you need more information, please let me know. Thanks for your help!

Abdelouahed

Reply to: