[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: r35215 - /website/howto/quilt.pod



On Mon, May 11, 2009 at 08:42:33PM -0000, dmn@users.alioth.debian.org wrote:
> Author: dmn
> Date: Mon May 11 20:42:28 2009
> New Revision: 35215
> 
> URL: http://svn.debian.org/wsvn/?sc=1&rev=35215
> Log:
> mention quilt 0.40 is available in Lenny
[snip]
>  N.B. F</usr/share/quilt/quilt.make> is available since C<quilt> version 0.40.
> -You are advised to make the quilt build-dependency versioned.
> +This version is available since Lenny, bu if you need to backport packages
> +using it to Etch and before, the build-dependency on C<quilt> should be
> +versioned.

Mmm, actually even Etch currently has quilt-0.45-6 :)  That's mainly
the reason why lots of packages outside the Perl Group have dropped
their (>= 0.40-1) in the past year or three.  It's only Sarge and
earlier that don't have 0.40 - Sarge has 0.39, I believe.

The only reason I'm keeping (>= 0.40-1) in the control file of
my personal etch-backports is to keep Etch's Lintian happy -
the oldish version there still complains about a missing dependency,
supposedly because Sarge was stable back then and lintian wanted to
help backports :)

So basically, even etch-backports don't really need this dependency
unless you want to avoid a lintian warning.

G'luck,
Peter

-- 
Peter Pentchev	roam@ringlet.net    roam@space.bg    roam@FreeBSD.org
PGP key:	http://people.FreeBSD.org/~roam/roam.key.asc
Key fingerprint	FDBA FD79 C26F 3C51 C95E  DF9E ED18 B68D 1619 4553
Do you think anybody has ever had *precisely this thought* before?

Attachment: pgpqT0iDCtrtD.pgp
Description: PGP signature


Reply to: