[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: perlapi and 5.8 and 5.10

On Fri, Oct 31, 2008 at 04:48:50PM +0000, Bob Wilkinson wrote:

>      I guess I would like to know whether I have done something wrong, and if
>      so, what. I find it strange that I should have to rebuild a package anew
>      for 5.10, unless, of course, there was an incompatible API change between
>      5.8 and 5.10

You didn't do anything wrong.  There was an incompatible change in the
XS module interface, though I think it should be called ABI and not API.

Just try to install the old version with dpkg --force-depends; 
you should see something like

/usr/lib/perl5/auto/Class/MethodMaker/MethodMaker.so: undefined symbol: Perl_Tstack_sp_ptr 

About 300 packages were rebuilt for the Debian 5.8->5.10 transition
back in May.
Niko Tyni   ntyni@debian.org

Reply to: