[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 5.8.0 -> 5.8.1 breakage on Debian: HTML::Parser failure



> > I understand that 5.8.1 is supposed to be binary compatible with
> > 5.8.0.  However, the Debian build of 5.8.1, is not compatible with the
> > Debian HTML::Parser binary package.  Rebuilding HTML::Parser (without
> > any source changes) fixed the failure.
> > 
> > Has anyone else experienced an upgrade difficulty of this kind?  Is
> > it, in the collective opinion of this august list, Debian-specific?
> 
> I don't know if it's Debian-specific, but I had to rebuild both xchat
> and apache (with mod_perl) because they were both segfaulting when
> trying to do perl stuff. Somebody also reported that irssi was
> segfaulting.

I've now also heard that libxml-simple-perl has stopped working under
Perl 5.8.1 when using libxml-libxml-perl (see bug #213652).  I haven't
proved it yet, but I suspect that rebuilding libxml-libxml-perl will fix
this problem, as well.

KEN

-- 
Kenneth J. Pronovici <pronovic@debian.org>

Attachment: pgp20Jtn1cm6q.pgp
Description: PGP signature


Reply to: