[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Perl mysteries.

On Tue, May 16, 2000 at 12:13:36AM +0100, Julian Gilbey wrote:
> > Maybe an additional Conflicts: perl-5.004-suid would work?
> Why?  There's no conflict there.

Maybe I got something wrong... sorry.

> > I don't know what's the point of having two versions of perl included,
> > anyway. Will anyone actually use the old version, when no modules are
> > compiled against it and it might cause newer code depending on just perl5 to
> > break?
>  - people might want to test code on perl-5.004 to see if it works
>    there as well as on perl-5.005 or perl-5.6.  Since it is possible
>    to have multiple versions of perl on a machine, it would make sense
>    to allow it.

Yeah, but how many people will actually need this? Is it worth it?

>  - if newer code needs perl-5.005, it should have a "use 5.005;" or
>    "require 5.005;" pragma in the code, and the package should Depend:
>    perl-5.005 | perl-5.6 (or whatever).

Right, I meant unable to load modules while running under perl-5.004, see my
reply to Steve's message...

Digital Electronic Being Intended for Assassination and Nullification

Reply to: