[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#663105: libreoffice-calc: list validation menus sometimes too small



Package: libreoffice-calc
Version: 1:3.4.5-2
Severity: wishlist

If I activate validation for a cell where accepted values are from a
list, the menu showing the list values is as wide as the cell itself.

There are cases, however, where this is not reasonable, and the
width should be the one of the widest list item.

In fact, when I set a cell to contain text that is longer than the
cell's width, either because the text spills over the cell on the right,
or because of text wrapping in the cell, then the text in the dropdown
menu becomes truncated and unreadable.

I do not observe this problem in Gnumeric, which, apparently, makes the
menu as wide as the widest entry in the list.

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'testing-proposed-updates')
Architecture: amd64 (x86_64)

Kernel: Linux 3.0.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.ISO-8859-15, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libreoffice-calc depends on:
ii  libc6                  2.13-26
ii  libcolamd2.7.1         1:3.4.0-2
ii  libgcc1                1:4.6.2-12
ii  libreoffice-base-core  1:3.4.5-2
ii  libreoffice-core       1:3.4.5-2
ii  libstdc++6             4.6.2-12
ii  lp-solve               5.5.0.13-7
ii  uno-libs3              3.4.5-2

libreoffice-calc recommends no packages.

libreoffice-calc suggests no packages.

Versions of packages libreoffice-core depends on:
ii  fontconfig                         2.8.0-3.1
ii  fonts-opensymbol [ttf-opensymbol]  2:2.4.3+LibO3.4.5-2
ii  libatk1.0-0                        2.2.0-2
ii  libc6                              2.13-26
ii  libcairo2                          1.10.2-6.2
ii  libcurl3-gnutls                    7.24.0-1
ii  libdb5.1                           5.1.29-1
ii  libexpat1                          2.0.1-7.2
ii  libfontconfig1                     2.8.0-3.1
ii  libfreetype6                       2.4.8-1
ii  libgcc1                            1:4.6.2-12
ii  libgdk-pixbuf2.0-0                 2.24.1-1
ii  libglib2.0-0                       2.30.2-6
ii  libgraphite2-2.0.0                 1.0.3.real-1
ii  libgstreamer-plugins-base0.10-0    0.10.36-1
ii  libgstreamer0.10-0                 0.10.36-1
ii  libgtk2.0-0                        2.24.10-1
ii  libhunspell-1.3-0                  1.3.2-4
ii  libhyphen0                         2.8.3-1
ii  libice6                            2:1.0.7-2
ii  libicu48                           4.8.1.1-3
ii  libjpeg8                           8d-1
ii  libmythes-1.2-0                    2:1.2.2-1
ii  libneon27-gnutls                   0.29.6-1
ii  libnspr4-0d                        4.9-1
ii  libnss3-1d                         3.13.3-1
ii  libpango1.0-0                      1.29.4-2
ii  libpng12-0                         1.2.47-1
ii  librdf0                            1.0.15-1
ii  libreoffice-common                 1:3.4.5-2
ii  libsm6                             2:1.2.0-2
ii  libssl1.0.0                        1.0.0g-1
ii  libstdc++6                         4.6.2-12
ii  libtextcat0                        2.2-10
ii  libx11-6                           2:1.4.4-4
ii  libxaw7                            2:1.0.9-3
ii  libxext6                           2:1.3.0-3
ii  libxinerama1                       2:1.1.1-3
ii  libxml2                            2.7.8.dfsg-7
ii  libxrandr2                         2:1.3.2-2
ii  libxrender1                        1:0.9.6-2
ii  libxslt1.1                         1.1.26-8
ii  libxt6                             1:1.1.1-2
ii  ttf-opensymbol                     2:2.4.3+LibO3.4.5-2
ii  uno-libs3                          3.4.5-2
ii  ure                                3.4.5-2
ii  zlib1g                             1:1.2.6.dfsg-1

-- no debconf information



Reply to: