[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#609657: libreoffice-gcj: needs versioned dependency on gcj compat package

Package: libreoffice-gcj
Version: 1:3.3.0~rc2-3
Severity: serious
Justification: Policy 7.2

When libreoffice-gcj is installed, but the version of the
Java-RTE-like interface of gcj (package gcj-jre or java-gcj-compat)
that is installed is not the right one, and LibreOffice is configured
to use gcj, LibreOffice aborts as soon as it tries to use java with
error message:
 libgcj failure: gcj linkage error.

The dependency on gcj-jre / java-gcj-compat should thus be versioned
accordingly to ensure that a compatible version is installed.

-- System Information:
Debian Release: squeeze/sid
  APT prefers stable
  APT policy: (500, 'stable'), (200, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_LU.UTF-8, LC_CTYPE=fr_LU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libreoffice-gcj depends on:
ii  bsh-gcj                2.0b4-12          Java scripting environment (BeanSh
ii  gcj-jre [java-gcj-comp 4:4.4.5-2         Java runtime environment using GIJ
ii  libc6                  2.11.2-7          Embedded GNU C Library: Shared lib
ii  libgcc1                1:4.3.2-1.1       GCC support library
ii  libgcj-bc              4.4.5-2           Link time only library for use wit
ii  libgcj-common          1:4.4.5-2         Java runtime library (common files
ii  libhsqldb-java-gcj        Java SQL database engine (native c
ii  libreoffice-core       1:3.3.0~rc2-3     office productivity suite -- arch-
ii  libreoffice-java-commo 1:3.3.0~rc2-3     office productivity suite -- arch-
ii  zlib1g                 1: compression library - runtime

libreoffice-gcj recommends no packages.

libreoffice-gcj suggests no packages.

Versions of packages libreoffice-core depends on:
ii  fontconfig         2.6.0-3               generic font configuration library
ii  libatk1.0-0        1.30.0-1              The ATK accessibility toolkit
ii  libc6              2.11.2-7              Embedded GNU C Library: Shared lib
ii  libcairo2          1.8.10-6              The Cairo 2D vector graphics libra
ii  libcurl3-gnutls    7.18.2-8lenny4        Multi-protocol file transfer libra
ii  libdb4.8           4.8.30-2              Berkeley v4.8 Database Libraries [
ii  libexpat1          2.0.1-4+lenny3        XML parsing C library - runtime li
ii  libfontconfig1     2.8.0-2.1             generic font configuration library
ii  libfreetype6       2.3.7-2+lenny4        FreeType 2 font engine, shared lib
ii  libgcc1            1:4.3.2-1.1           GCC support library
ii  libglib2.0-0       2.24.2-1              The GLib library of C routines
ii  libgraphite3       1:2.3.1-0.2           SILGraphite - a "smart font" rende
ii  libgstreamer-plugi 0.10.30-1             GStreamer libraries from the "base
ii  libgstreamer0.10-0 0.10.30-1             Core GStreamer libraries and eleme
ii  libgtk2.0-0        2.20.1-2              The GTK+ graphical user interface 
ii  libhunspell-1.2-0  1.2.11-1              spell checker and morphological an
ii  libhyphen0         2.4-4                 ALTLinux hyphenation library - sha
ii  libice6            2:1.0.4-1             X11 Inter-Client Exchange library
ii  libicu44           4.4.2-1               International Components for Unico
ii  libjpeg62          6b1-1                 The Independent JPEG Group's JPEG 
ii  libmythes-1.2-0    2:1.2.1-1             simple thesaurus library
ii  libneon27-gnutls   0.29.3-3              An HTTP and WebDAV client library 
ii  libnspr4-0d        4.8.6-1               NetScape Portable Runtime Library
ii  libnss3-1d         3.12.8-1              Network Security Service libraries
ii  libpango1.0-0      1.28.3-1              Layout and rendering of internatio
ii  libpng12-0         1.2.27-2+lenny4       PNG library - runtime
ii  librdf0            1.0.10-3              Redland Resource Description Frame
ii  libreoffice-common 1:3.3.0~rc2-3         office productivity suite -- arch-
ii  libsm6             2:1.0.3-2             X11 Session Management library
ii  libssl0.9.8        0.9.8o-2              SSL shared libraries
ii  libstdc++6         4.4.5-10              The GNU Standard C++ Library v3
ii  libx11-6           2:1.3.3-3             X11 client-side library
ii  libxaw7            2:1.0.4-2             X11 Athena Widget library
ii  libxext6           2:1.0.4-2             X11 miscellaneous extension librar
ii  libxinerama1       2:1.1-3               X11 Xinerama extension library
ii  libxml2            2.7.8.dfsg-1          GNOME XML library
ii  libxrandr2         2:1.3.0-3             X11 RandR extension library
ii  libxrender1        1:0.9.4-2             X Rendering Extension client libra
ii  libxslt1.1         1.1.26-6              XSLT 1.0 processing library - runt
ii  libxt6             1:1.0.5-3             X11 toolkit intrinsics library
ii  ttf-opensymbol     1:3.2.1-7             OpenSymbol TrueType font
ii  ure                1.7.0+LibO3.3.0~rc2-3 LibreOffice UNO runtime environmen
ii  zlib1g             1:     compression library - runtime

Versions of packages libreoffice-java-common depends on:
ii  libreoffice-common         1:3.3.0~rc2-3 office productivity suite -- arch-

-- no debconf information

Reply to: