[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#609594: [openoffice.org-calc] Freezes when opening a file

On Monday 10 January 2011 21:26:10 Sven Eckelmann wrote:
> Package: openoffice.org-calc
> Version: 1:3.2.1-11
> Severity: normal
> The attached file was stored with OpenOffice.org calc 1:3.2.1-11. The
> application will "freeze" when it tries to open the file.

I tried to open it with libreoffice-calc 1:3.3.0-rc2-3 from experimental and 
it worked perfectly with it (no, crash or freeze - just a question if it 
should open it in readonly or normal mode because he thinks that it is open 
from another system.... but it also seemed to work after reinstalling 
openoffice.org-calc again (which is a little bit mysterious because the freeze 
could be tested on many different systems).

The next step was to install the complete openoffice.org packet including the 

libcommons-beanutils-java{a} libcommons-collections3-java{a} libcommons-
compress-java{a} libcommons-digester-java{a} libcommons-logging-java{a} libdb-
je-java{a} libdb4.7-java{a} libdb4.7-java-gcj{a} libhsqldb-java{a} libicu4j-
java{a} libjaxp1.3-java{a} libjline-java{a} libjtidy-java{a} liblucene2-
java{a} libregexp-java{a} libservlet2.5-java{a} libwps-0.1-1{a} openoffice.org 
openoffice.org-base{a} openoffice.org-draw{a} openoffice.org-emailmerge{a} 
openoffice.org-filter-binfilter{a} openoffice.org-filter-mobiledev{a} 
openoffice.org-impress{a} openoffice.org-java-common{a} openoffice.org-math{a} 
openoffice.org-officebean{a} openoffice.org-report-builder-bin{a} 
openoffice.org-writer{a} python-uno{a} ttf-sil-gentium-basic{a}

The problem could be easily reproduced afterwards.

I removed the complete openoffice.org installation and tried to add different 
dependencies to the system next to openoffice.org-calc.

Following packages must be installed to create that freeze (remove one of it 
and it didn't happen anymore):
 * openoffice.org-calc
 * openoffice.org-filter-mobiledev
 * openoffice.org-impress
 * openoffice.org-writer
 * openoffice.org-filter-binfilter
 * (dependencies/recommendations for the mentioned packages)

On Monday 10 January 2011 22:26:00 Rene Engelhard wrote:
> > So it looks to me like the java stuff is broken. I tried to replace
> > openjre and openjdk-6-jre-headless 6b18-1.8.3-2 with sun-java6-jre
> > 6.22-1, but the results were the same for me.
> Hmm. They work for the stuff actually using Java, though, and opening
> ods shouldn't require/use Java anyways. What do you have inside that ods?

The file were given to me with the information that it freezes OOo. Afaik only 
normal calculations and some color markings were done with it (no java or 
script stuff).

Best regards,

Attachment: signature.asc
Description: This is a digitally signed message part.

Reply to: