[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#566189: openoffice.org: Openoffice crashes on startup

forwarded 566189 Thorsten Behrens <thb@openoffice.org>
retitle 566189 openoffice.org: Openoffice crashes on startup with DeploymentException


On Fri, Jan 22, 2010 at 12:09:25AM +0100, Rene Engelhard wrote:
> On Thu, Jan 21, 2010 at 10:38:48PM +0100, Ferry Toth wrote:
> > After upgrading today from openoffice.org (1:3.1.1-8) to 1:3.1.1-14, Openoffice crashes immediately on startup.
> > 
> > Starting from the command line lets me pick the document type, then crashes as well with:
> > 
> > terminate called after throwing an instance of 'com::sun::star::deployment::DeploymentException'
> > 
> > Deleting .openoffice.org did not help.
> We just had the same case on IRC and it turned out to be a corrupt
> file. 

... which according to upstream is a real bug. (set fwd)

> He removed the whole directory (com.sun.star.comp.deployment.component.PackageRegistryBackend; you can also remove everything below cache if you wish)
> and then it works. (Of course if you want all the extensions then you
> need to reinstall the packages; ignore the errors about not existing extensions
> before unpacking, they're expected in this case)

Use this hackaround for now.

> I'll now try to debootstrap an old squeeze wizth 1:3.1.1-8, install
> OOo with some extensions and upgrade...

Interestingly I can't reproduce this in a 1:3.1.1-8->1:3.1.1-14 upgrade
(installed: openoffice.org openoffice.org-sdbc-postgresql)


 .''`.  René Engelhard -- Debian GNU/Linux Developer
 : :' : http://www.debian.org | http://people.debian.org/~rene/
 `. `'  rene@debian.org | GnuPG-Key ID: D03E3E70
   `-   Fingerprint: E12D EA46 7506 70CF A960 801D 0AA0 4571 D03E 3E70

Reply to: