[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#534243: openoffice.org-core: Please switch to libneon27-gnutls

On Fri, Aug 14, 2009 at 06:13:14PM +0200, Rene Engelhard wrote:
> Hi,

Hi René,

> On Tue, Jun 23, 2009 at 01:22:43PM +0300, Adrian Bunk wrote:
> > > Anyway, I'll fix this but I am not convinced that we should move from
> > > SSl to Gnutls (except for curl which must be at gnutls for now because
> > > of librdf0-dev. When it'll be removed with 3.2 I'll switch that to openssl, too)
> Still holds. Especially as a core library of OOo (OOXML import) will also
> use OpenSSL. I don't think we should depend on a -gnutls flavour of something
> directly then. :)

following this logic, you also have to request OpenLDAP libraries linked 
against OpenSSL from the OpenLDAP maintainers. If you aren't doing that, 
your point it kinda moot...

Does OOo care at all which TLS library OpenLDAP/libcurl/libneon use?

> See #534243, the attached issue and the patch there ;-). Can we close this?
> Otherwise it probably would simply be wontfix forever unless some build-dep
> conflict forces me to use -gnutls, and be it temporarily.

Although some have been fixed, 6 RC bugs I reported for GPLed software 
linked against libcurl3/libneon27 are still open - this is a common trap 
for GPL violations.

That's my rationale for wanting to get rid of them.

If you have any technical reason why OOo 3.1 does work worse with 
libneon27-gnutls than with libneon27 that would make me agree to
close this bug.

> Grüße/Regards,
> Rene



       "Is there not promise of rain?" Ling Tan asked suddenly out
        of the darkness. There had been need of rain for many days.
       "Only a promise," Lao Er said.
                                       Pearl S. Buck - Dragon Seed

Reply to: