[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#452925: javasettings_*.xml from previous version still troublesome


I've upgraded (on Etch) to 1:2.3.1-2~bpo40+1 and then I see the error
  javaldx failed!
and some actions make ooo crash (eg trying to email the current doc - btw, 
ooo needs java just to spawn a mailer?!?).

It's not exactly same bug as 452925, nevertheless it share most of the 
'features' - namely, I don't get the 'could not load Java runtime library'
error, but simply seems ooo won't store the jvm setting.

In #452925 was mentioned that javasettings_x86.xml was the culprit, a 
problem which should have been addressed by a ~recent patch.
Seems the fix wasn't complete though: I see an old javasettings_Linux_x86.xml
with old data: 


Removing it solved the problem, ooo stored the jvm setting and emailng worked;
what puzzle me, is that the config was written in same file:


and old (blocking) and 'new' file look pretty much the same (except for the 
fields value of course):

$ ls -l .openoffice.org2/user/config/javasettings*
-rw-r--r-- 1 paolo paolo 1622 2008-03-09 09:57 .openoffice.org2/user/config/javasettings_Linux_x86.xml
-rw-r--r-- 1 paolo paolo 1624 2008-03-09 09:27 .openoffice.org2/user/config/javasettings_Linux_x86.xml.old

so why ooo did not just update the data in the .xml ?

BTW, as mentioned by #452925 originator, imo it'd be saner to use the 
link instead of the versioned path
so that jvm upgrade won't break ooo settings (at least until jvm major.minor
version remains the same).

 GPG/PGP id:0x3A47DE45  - B5F9 AAA0 44BD 2B63 81E0  971F C6C0 0B87 3A47 DE45
 - 9/11: the outrageous deception and ongoing coverup: http://911review.org -

Reply to: