[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

upstream build progress report



Rene,

I built upstream OOF680_m14 on GNU/Linux SPARC on debian/unstable
first build using gcc4.1.2,  then built again with gcc-3.3 for my upload.

In both cases I used java-gcj-compat-dev and ant-1.7.0RC1
There were no new build issues for gcc-4.1.2.

I configured like this:
--with-ant-home=/usr/local/apache-ant-1.7.0RC1
--with-jdk-home=/usr/lib/jvm/java-1.4.2-gcj-4.1-1.4.2.0
--with-package-format=rpm
--with-alloc=system
--enable-crashdump=STATIC
--enable-symbols=SMALL

For gcc-4.1.2 building m206 and later one patch is needed:
http://qa.openoffice.org/issues/show_bug.cgi?id=76191

For gcc3.3 building OOF680_m14 four patches:
http://qa.openoffice.org/issues/show_bug.cgi?id=75971
http://qa.openoffice.org/issues/show_bug.cgi?id=75989
http://qa.openoffice.org/issues/show_bug.cgi?id=75990
http://qa.openoffice.org/issues/show_bug.cgi?id=75996

I build everything that builds by default (no --with-system modules).

But I need --with-alloc=system since issue 65788:
http://qa.openoffice.org/issues/show_bug.cgi?id=65788

thanks

jim



Reply to: