[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#343942: openoffice.org: error because of missing XLB script on saving a document

I was having the same problems .
While the kludge to the user configuration that I submitted earlier did
work it bothered me.

Looked closer at my uno packages that were used to set system wide
defaults and found a couple problems.

Had this in Setup.xcu:

 <node oor:name="Office">
  <prop oor:name="ooSetupInstCompleted" oor:type="xs:boolean">

Had this in Common.xcu:

 <node oor:name="Misc">
  <prop oor:name="FirstRun" oor:type="xs:boolean">

Removed both from my uno files and all is well.
Actually pretty sure it was the first one that caused the damage.

Curious if others having this error have somehow tampered with the users
 initial configuration?


Friedemann Schorer wrote:
> Package: openoffice.org
> Version: 2.0.0-5
> Severity: normal
> When I edit a document (tested only with ODT) and hit the save button, I
> get an error, saying "error while loading BASIC of the document 
> file://usr/lib/openoffice/share/basic/WebWizard/script.xlb
> Common error
> comon I/O-error"
> (translated roughly from german, I hope it suffices).
> a second error is also given, complainig about a mising file
> "dialog.xlb" in the same dir.
> Nevertheless, the file seems to be saved without problems.
> Pls. let me know if you need more info to track this down, and I'd like
> to thank you for all your work!
> 	Friedemann 
> -- System Information:
> Debian Release: testing/unstable
>   APT prefers testing
>   APT policy: (990, 'testing'), (500, 'unstable'), (500, 'stable'), (1, 'experimental')
> Architecture: i386 (i686)
> Shell:  /bin/sh linked to /bin/bash
> Kernel: Linux 2.6.12-1-k7
> Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro (charmap=ISO-8859-15)
> Versions of packages openoffice.org depends on:
> ii  openoffice.org-base           2.0.0-5    OpenOffice.org office suite - data
> ii  openoffice.org-calc           2.0.0-5    OpenOffice.org office suite - spre
> ii  openoffice.org-core           2.0.0-5    OpenOffice.org office suite archit
> ii  openoffice.org-draw           2.0.0-5    OpenOffice.org office suite - draw
> ii  openoffice.org-impress        2.0.0-5    OpenOffice.org office suite - pres
> ii  openoffice.org-java-common    2.0.0-5    OpenOffice.org office suite Java s
> ii  openoffice.org-math           2.0.0-5    OpenOffice.org office suite - equa
> ii  openoffice.org-writer         2.0.0-5    OpenOffice.org office suite - word
> openoffice.org recommends no packages.
> -- no debconf information

John McMonagle
IT Manager
Advocap Inc.

Reply to: