[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#268172: debian/rules: getting berkeleydb version fails due to CVS-Directory

Package: openoffice.org
Version: 1.1.2-3
Severity: normal
Tags: patch

When built on Woody, openoffice tries to get berkleydb's version in debian/rules,
Line 156 by calling
  ls -1 berkeleydb/download | cut -d"-" -f2 | cut -d"." -f1,2
However, there is a CVS-Directory present, so this approach fails. A quick solution
is to add a |grep -v CVS.

<   D=$(shell ls -1 berkeleydb/download | cut -d"-" -f2 | cut -d"." -f1,2)
>   D=$(shell ls -1 berkeleydb/download | cut -d"-" -f2 | cut -d"." -f1,2 | grep -v CVS)

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux cipsc 2.4.27-rc5-cipsc #1 SMP Fri Aug 6 16:48:09 CEST 2004 i686
Locale: LANG=C, LC_CTYPE=de_DE@euro

Reply to: