[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build-dependency on libpam0g-dev missing



Hi,

Jérôme Warnier wrote:
> It fails miserably like this if not present:
> 
> ------------------------------
> Making: ../../unxlngi4.pro/obj/security.obj
> ccache gcc-3.0 -fmessage-length=0 -c -I.  -I. -I../inc -I../../inc
> -I../../unx/inc -I../../unxlngi4.pro/inc -I.
> -I/home/jwarnier/debian/ooo/openoffice.org-1.0.99+1.1rc/build-tree/oo_1.1rc_src/solver/645/unxlngi4.pro/inc/dont_use_stl -I/home/jwarnier/debian/ooo/openoffice.org-1.0.99+1.1rc/build-tree/oo_1.1rc_src/solver/645/unxlngi4.pro/inc/external -I/home/jwarnier/debian/ooo/openoffice.org-1.0.99+1.1rc/build-tree/oo_1.1rc_src/solver/645/unxlngi4.pro/inc -I/home/jwarnier/debian/ooo/openoffice.org-1.0.99+1.1rc/build-tree/oo_1.1rc_src/solenv/unxlngi4/inc -I/home/jwarnier/debian/ooo/openoffice.org-1.0.99+1.1rc/build-tree/oo_1.1rc_src/solenv/inc -I/home/jwarnier/debian/ooo/openoffice.org-1.0.99+1.1rc/build-tree/oo_1.1rc_src/res -I/home/jwarnier/debian/ooo/openoffice.org-1.0.99+1.1rc/build-tree/oo_1.1rc_src/solver/645/unxlngi4.pro/inc/dont_use_stl -I/home/jwarnier/debian/ooo/openoffice.org-1.0.99+1.1rc/build-tree/oo_1.1rc_src/solenv/inc/Xp31 -I/usr/lib/j2se/1.3/include -I/usr/lib/j2se/1.3/include/linux -I/usr/lib/j2se/1.3/include/native_threads/include -I/usr/X11R6/include     -I. -I../../res -I. -O1   -pipe -mcpu=pentiumpro   -DLINUX -DUNX -DVCL -DGCC -DC300 -DINTEL -DCVER=C300 -D_USE_NAMESPACE -DGLIBC=2 -DX86 -D_PTHREADS -D_REENTRANT -DNEW_SOLAR -D_USE_NAMESPACE=1 -DSTLPORT_VERSION=400 -D__DMAKE -DUNIX -DCPPU_ENV=gcc3 -DSUPD=645 -DBUILD=8639 -DPRODUCT -DNDEBUG -DPRODUCT_FULL -DOSL_DEBUG_LEVEL=0 -DOPTIMIZE -DEXCEPTIONS_OFF -DCUI -DSOLAR_JAVA -DSRX645  -DMULTITHREAD   -o ../../unxlngi4.pro/obj/security.o security.c
> security.c:136:31: security/pam_appl.h: No such file or directory

Build-Depends: [..] libpam9g-dev | libpam-dev is there....

and:

bin/sh-2.05a# sudo apt-get install libpam-dev
Reading Package Lists...
Building Dependency Tree...
Note, selecting libpam0g-dev instead of libpam-dev
The following NEW packages will be installed:
  libpam0g-dev

That Build-Dependency should be fullfilled. libpam0g-dev contains this
header and is the only package providing libpam-dev....

bin/sh-2.05a# grep-available -FProvides libpam-dev | grep Package:
Package: libpam0g-dev
bin/sh-2.05a#

(both actions done in my woody chroot)

Hmm...

Grüße/Regards,

René
-- 
 .''`.  René Engelhard -- Debian GNU/Linux Developer
 : :' : http://www.debian.org | http://people.debian.org/~rene/
 `. `'  rene@debian.org | GnuPG-Key ID: 248AEB73
   `-   Fingerprint: 41FA F208 28D4 7CA5 19BB  7AD9 F859 90B0 248A EB73
      

Attachment: pgpzS1XTwTpHB.pgp
Description: PGP signature


Reply to: