[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [RESOLVED] gnome2.2 woody backport and semi-official openoffice.org backport freetype issue

On Tue, 2003-04-15 at 11:05, Wouter Hanegraaff wrote:
> On Thu, Apr 10, 2003 at 12:02:07PM -0400, James D Strandboge wrote:
> > Woody ships with freetype 2.0.9 while my gnome2.2 backport uses freetype
> > 2.1.3.  After some investigation and testing, I have found that gnome
> > 2.2 does not actually require freetype 2.1.3.  Due to people wanting to
> > use the semi-official openoffice.org packages
> > (http://www.linux-debian.de/openoffice/) and the potential problems with
> > using freetype 2.1.3 on a woody system, I have recompiled packages in my
> > backport to use the woody version of freetype.  This should resolve any
> > issues with the semi-official openoffice.org.
> Nice, but now they conflict with the woody backports of xfree86 4.3
> listed at http://www.apt-get.org/list.php?site=236, which is needed for
> many newer videocards. Yes, I know, by mixing backports I risk these
> kind of problems.
Well, there is only so much I can do to resolve problems with mixing
backports.  :)  

> So I'll stick with the previous gnome2.2 which includes freetype 2.1.3,
> or maybe upgrade my desktops to unstable :-(.  I'm open to better
> suggestions though.
Needing gnome2.2, xfree86 4.3 and latest openoffice.org?  I'd say you
are a good candidate for unstable.  You could also wait and see what
happens with testing.  

You don't actually HAVE to downgrade the freetype now-- all the apps
(minus a couple libraries) will install without downgrading.  However,
subtle incompatibilities may exist which could cause problems (one of
the reasons why I downgraded it in the first place).  

If you decide to 'dpkg-buildpackage' xfree86 4.3, you may also run into
other problems.  One is 4.3 may require the higher freetype version. 
Another is the woody gnome2.2 backport also requires libxft2, but the
version of xft2 (and fontconfig for that matter) that comes with 4.3 is
higher and may be incompatible with the version that must be installed
with the backport (ie libxft2 dpkg-diverts the libXft2.  With 4.2, that
is ok, because libxft2 package had a better version of libXft2, but with
4.3, who knows what will happen?).

Considering you *NEED* xfree86 4.3 and *WANT* gnome2.2, I recommend
upgrading to sid.


Email:        jstrand1@rochester.rr.com
GPG/PGP ID:   26384A3A
Fingerprint:  D9FF DF4A 2D46 A353 A289  E8F5 AA75 DCBE 2638 4A3A

Reply to: