[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Pkg-octave-devel] Bug#524745: marked as done (Postinst seems to run forever on mipsel)

Your message dated Sat, 09 May 2009 12:55:42 +0200
with message-id <4A05612E.8000409@debian.org>
and subject line Re: Bug#524745: give back drivel on mips and mipsel ?
has caused the Debian Bug report #524745,
regarding Postinst seems to run forever on mipsel
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

524745: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=524745
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: octave3.0
Version: 1:3.0.5-2
Severity: grave


The postinst of octave3.0 seems to hang on at least the mipsel buildds (for unstable) [1].

This issue blocks the buildds from building any other package till the octave3.0 process (mentioned in the build log) is killed manually. This has already caused delays for security updates and transitions...



[1] https://buildd.debian.org/fetch.cgi?&pkg=octave-octcdf&ver=1.0.11-2&arch=mipsel&stamp=1240130079&file=log

--- End Message ---
--- Begin Message ---
Rafael Laboissiere wrote:
> * Philipp Kern <pkern@debian.org> [2009-05-08 11:13]:
>> On Fri, May 08, 2009 at 09:51:05AM +0200, Adeodato Simó wrote:
>>> + Rafael Laboissiere (Fri, 08 May 2009 08:51:05 +0200):
>>>>> That's caused by a kernel bug on the mipsen buildds. It's not fixed, but
>>>>> a workaround has been introduced in glibc 2.9-9 or so that enables popen()
>>>>> et al. to work again. :-)
>>>> Is there any chance that this problem is also causing Bug#524745?
>>> No, I don't think so, since IIRC it also happened in (at least) powerpc
>>> and armel. Hopefully somebody can confirm that (Phil CC'ed for that).
>> At that time I happened almost everywhere, so it's certainly not a kernel
>> bug on mipsen only.  (I raised that to the bug report.)
>> I didn't see it again since then, though.  Don't know if nothing octave-ish
>> has been retried or if there was a  fix somewhere.
> To the best of my knowledge, no buildd of the octave-* packages has been
> attempted on mipsel since a while.  I did send a give-back request to
> debian-wb-team@l.d.o, but nothing seems to happen.

Nothing conclusive happened since then, but octave3.0 was getting built
and one octave3.0 build depending package was tried.

> I am really frustrated with this bug and I have the impression we
> are going nowhere.  I cannot believe that there is something wrong with
> the packages, since some of them had successful buildds against
> octave3.0, version 1:3.0.5-2:

The bug (and the buildd) was stuck for quite some days on your input on
how to debug it...

We still don't know what caused it nor what fixed it, but it seems to be
fixed now, so I'm closing this bug and will give back all packages.

> Curiously enough, the builds above were done on April 14, 2009.  The
> failed builds due to the hanging octave3.0 postinst script seem to have
> happened after that date.  Did anything change on the mipsel autobuilders
> around that date? 

Probably the buildds got an upgraded toolchain.



--- End Message ---

Reply to: