[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#638014: libsdl-ocaml-dev: sdlgfx.cm[x]a are missing

Package: libsdl-ocaml-dev
Version: 0.8.0-2
Severity: normal

sdlgfx.cma and sdlgfx.cmxa are not present in the package. However
sdlgfx.mli is present and both sdlgfx.cma and sdlgfx.cmxa are
mentionned in the META file.

libsdl-gfx*[-dev] are neither a build-depency neither a depency. When
libsdl-gfx1.2-dev is present at compile time, the source package
correctly builds and packages the missing files.

Adding a [build-]dependy to libsdl-gfx*[-dev] should provide
sdlgfx.cma and sdlgfx.cmxa.

Thank you for the good job on the ocaml packages.

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
APT policy: (900, 'testing'), (700, 'stable'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.39-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libsdl-ocaml-dev depends on:
ii liblablgl-ocaml-dev [liblablg 1.04-5+b2 an OpenGL interface for Objective ii libsdl-image1.2-dev 1.2.10-2.1 development files for SDL 1.2 imag ii libsdl-mixer1.2-dev 1.2.8-6.3 development files for SDL1.2 mixer ii libsdl-ocaml [libsdl-ocaml-en 0.8.0-2 OCaml bindings for SDL - runtime f ii libsdl-ttf2.0-dev 2.0.9-1 development files for SDL ttf libr ii libsdl1.2-dev 1.2.14-6.4 Simple DirectMedia Layer developme ii ocaml-nox [ocaml-nox-3.12.0] 3.12.0-7 ML implementation with a class-bas

libsdl-ocaml-dev recommends no packages.

Versions of packages libsdl-ocaml-dev suggests:
ii ocaml-findlib 1.2.7+debian-1 management tool for OCaml librarie

-- debconf-show failed

Reply to: