[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#637147: libapache2-mod-ocamlnet: Error loading shared library: /usr/lib/ocaml/stublibs/dllnetsys.so

tags 637147 + upstream

Le 09/08/2011 22:39, Anders Peter Fugmann a écrit :
> I replaced apache2.conf with this:
> LoadModule netcgi_module /usr/lib/apache2/modules/mod_netcgi_apache.so
> NetcgiLoad pcre/pcre.cma
> NetcgiLoad netsys/netsys.cma
> #NetcgiLoad netstring/netstring.cma
> #NetcgiLoad str.cma
> #NetcgiLoad netcgi2/netcgi.cma
> #NetcgiLoad netcgi_apache/netcgi_apache.cma

According to the error messages, you need to add, before loading netsys.cma:

  NetcgiLoad bigarray.cma
  NetcgiLoad netsys/netsys_oothr.cma

If you need threads, use the following instead:

  NetcgiLoad bigarray.cma
  NetcgiLoad threads/threads.cma
  NetcgiLoad netsys/netsys_oothr_mt.cma

This doesn't seem to be documented in Netcgi_apache doc, though.

I will contact upstream about that, but my guess is that it is the doc
that is faulty.



Reply to: