[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Caml-list] Python and Caml

Le 27/11/2007 18:05, Thomas Fischbacher a écrit :

This link is broken.

(Note ad Debian developers: this fixes some major memory management bugs
that can cause crashes in the original pycaml module which is in Debian,
so, ideally, our variant should eventually supersede the code that is at
present in that Debian package. Interface-wise, our module provides more
than the original one, but I think I also had to remove two or three
very obscure functions.)

If you still think that, you should file a bugreport [1] against the pycaml package... or at least notify the Debian OCaml Maintainers list (in CC)...

Given the patches applied to the Debian packages that merely adapt it to newer Python versions, the absence of new upstream release for 6 years now, the absence of Art Yerkes in this thread (by the way, I put him in CC of this mail), I consider this project "dead" upstream. It would be nice if someone could take over upstream maintenance, and at least incorporate our patches [2] (or any other variant) for wider distribution.

As far as Debian is concerned, only coccinelle [3] depends on pycaml.

[1] http://www.debian.org/Bugs/Reporting
[2] http://patch-tracker.debian.org/package/pycaml
[3] http://coccinelle.lip6.fr/



Reply to: