[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#528241: dh-ocaml: Use << for Replaces, not <=?

Package: dh-ocaml
Version: 0.4.1
Severity: wishlist
User: ubuntu-devel@lists.ubuntu.com
Usertags: origin-ubuntu karmic

dh-ocaml Replaces: ocaml (<= 3.10.2-3) et al. Unfortunately this causes
problems for Ubuntu builds, where we had /usr/bin/dh_ocaml in ocaml-nox
version 3.10.2-3ubuntu1. Now we can bring ocaml back into sync with
Debian, except for the fact that our ocaml build fails due to the file
conflict between dh-ocaml and the older ocaml-nox:


Would you consider changing the Replaces to look like this instead? It's
still correct for Debian, and would fix this kind of problem for derived

  Replaces: ocaml (<< 3.11.0beta1-1), ocaml-base (<< 3.11.0beta1-1), ocaml-base-nox (<< 3.11.0beta1-1), ocaml-nox (<< 3.11.0beta1-1)


Colin Watson                                       [cjwatson@ubuntu.com]

Reply to: