[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Packages file for Etch corrupt?

Hi list,

I was creating a debian mirror with debmirror (creates the mirror by
downloading the Packages-file and then all packages mentioned by it) and
it failed. I tried to evaluate this a little further, and I found out
that several files, which are in Etch's Packages file, were missing on
the mirrors. The funny thing is, that these files are referenced by
packages.debian.org, and also get a file not found error. I tried this
with the following file as an example:


If you select to download this file on a mirror, it fails with a 404.

But this file is mentioned in the Packages file:

$ wget -O - -q "http://ftp.de.debian.org/debian/dists/etch/main/binary-amd64/Packages.bz2"; | bzcat | grep loop-aes-modules-2.6.18-4

Package: loop-aes-modules-2.6.18-4-xen-amd64
Filename: pool/main/l/loop-aes/loop-aes-modules-2.6.18-4-xen-amd64_3.1d-13_amd64.deb

It seems, that these files are refenecing the old kernel 2.6.18-4, but
what to do from then on is not clear to me.

This error at leasts concerns main and contrib sections in etch on
architectures amd64, i386 and powerpc.



Reply to: