[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cannot poweroff debian/mips64el on qemu

Thanks, Peter.

Here is the commandline.  The board is Malta board.  On the 32bit
version which worked, it is also Malta board, but it could be the
kernel difference.

If you could point out where the code is, I'd be more than happy to fix it.



qemu-system-mips64el \
    -M malta \
    -cpu MIPS64R2-generic \
    -m $GUEST_MEM \
    -hda hda.qcow2 \
    -kernel vmlinux \
    -initrd initrd.img \
        -append "root=/dev/sda1 console=ttyS0 nokaslr" \
    -nographic \
    -net user,hostfwd=tcp::2222-:22,hostfwd=tcp::8080-:80,hostfwd=tcp::8443-:443
    -net nic \
    -serial mon:stdio \

On Mon, Jan 20, 2020 at 2:41 AM Peter Maydell <peter.maydell@linaro.org> wrote:
> On Sun, 19 Jan 2020 at 22:40, Jun Sun <jsun@junsun.net> wrote:
> >
> > When I do "poweroff" from debian/mips64el on qemu, qemu will hang in
> > the end, rather than quitting the process.  See the kernel messages
> > below. Last time when I tried 32bit debian/mipsel I was able to quit
> > qemu completely.  Any thoughts?
> Whether this is expected to work depends on the board model
> (you don't give your QEMU command line). "exit the QEMU process"
> happens when the guest powers down the emulated hardware,
> so for this to work:
>  * the h/w board being modelled needs to actually have a
>    software-controllable powerdown feature (eg some device
>    register the guest has to prod)
>  * the QEMU model of that board needs to actually implement
>    whatever the powerdown control is
>  * the guest OS has to know about the control feature and
>    use it
> thanks
> -- PMM

Reply to: