[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#881845: rustc: FTBFS on mips*: test failures



Hi,

On 15/11/17 17:30, Emilio Pozuelo Monfort wrote:
> Source: rustc
> Version: 1.21.0+dfsg1-3
> Severity: important
> 
> Hi,
> 
> Sometime ago I asked about rustc bootstrap status on mips*:
> 
> 17:08 < infinity0> mips* fail many tests last time i tried, ~3 months ago, i didn't want to ship it, i haven't had time to check since
> 
>>From https://buildd.debian.org/status/fetch.php?pkg=rustc&arch=mips&ver=1.14.0%2Bdfsg1-3&stamp=1484077706&raw=0
> 
> test net::tcp::tests::timeouts ... FAILED
> test net::udp::tests::timeouts ... FAILED
> test sys::imp::ext::net::test::timeouts ... FAILED
> 
> Looks like timeouts are broken on rust/mips?
> 
> mips64el has different errors:
> 
> test f32::f32::tanh_0 ... FAILED
> test f64::f64::tanh_0 ... FAILED
> test io::error::Error::from_raw_os_error_0 ... FAILED
> 
> Maybe the mips porters can take a look? (debian-mips@ on Cc). Note those
> errors are for 1.14.0, you'll want to try with a newer version first and
> see what's the current status.

I just tried building the latest rustc on mips64el. As I expected, I hit
this LLVM bug again where any code using atomics will hang:

https://bugs.llvm.org/show_bug.cgi?id=32020

I'll see if I can get Simon to have a look at it again.

James

Attachment: signature.asc
Description: OpenPGP digital signature


Reply to: