[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

(Hardware?) problem with denormal values on mipsel

Dear Mailing list,

a few weeks ago, I found a problem that I thought is related to gfortran;
however I am unsure whether this is really the case.


Basically it burns down to the following minimal code on eder.debian.org:

(sid_mipsel-dchroot)olebole@eder:~$ cat aini.f
(sid_mipsel-dchroot)olebole@eder:~$ gfortran -Wall -o aini aini.f
(sid_mipsel-dchroot)olebole@eder:~$ ./aini

Program received signal SIGILL: Illegal instruction.

Backtrace for this error:
#0  0x778CFDDB
Illegal instruction (core dumped)

Similarly this happens on the buildd machines (see the bug report for a
build log).

I recently got a CI20 to play with and tried the same there, but I couldn't
reproduce the crash (also eso-midas compiles there without problems).
Unfortunately, eder.debian.org is not accessible in the moment, so I can't
re-check this. However, the gfortran compiler (4.9.2-10) is still the same,
and the build environment was sid on eder, and is jessie on my CI20, so they
are quite similar.

The CI20 probably uses another processor, which I would suspect now is the
cause for the problem. Is there anything special with the Debian mips
machines that their processors don't run the full instruction set?

How should I deal with this case? Is this a gfortran problem, a hardware
problem of the Debian machines, or did I setup something wrong when
compiling there?

Best regards


Reply to: