[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#623014: gcc-defaults: please default to gcc-4.5 on mips and mipsel

Package: gcc-defaults
Version: 1.102
Severity: wishlist

Now that gcc-4.5 seems to be in a good shape, I think it's time to 
make it the default on mips and mipsel. Note that it introduces a few
- The default ABI in gcc-4.5 is MIPS II instead of MIPS I. It means that
  it's not necessary anymore to use '.set mips2' pseudo ops in assembly 
  code to get access to the atomic instructions (ll, sc, lld, scd).
  gcc-4.5 also doesn't emit any more delay slot after load/store
  instructions, which slightly reduce the size of the generated 
  binaries. The drawback is that MIPS3000 CPUs are not supported 
  anymore. It should not be a big deal, especially given we don't 
  provide kernels for these CPUs for years. 
- gcc-4.5 enables PLT and copy relocation extensions of MIPS ABI by
  default (-mplt), which produces faster binaries.

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: mips (mips64)

Kernel: Linux 2.6.32-5-5kc-malta
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Reply to: