[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unable to install Debian/MIPS on Cobalt

Hi everyone,

I'm the owner of a Cobalt Raq2 with 256 MB RAM and an 80 GB hard
drive.  I'm wanting to turn it into a caching DNS and caching proxy
server.  To do this, I need to get it running.

I tried installing Gentoo on it.  I spent an entire day fighting with
it, and could never get it anywhere near being able to boot.  No one
seems to have done any updating on it for about 2 years.

I'm currently trying to install Debian on it.  I can get it to
netboot.  I can use a serial connection or SSH to connect in to run
the installer.  DHCP sets up the network for me.  I can partition the
hard drives.  I can pick a mirror.  It downloads and installs a pile
of stuff.

It never completes.  When it tries to download the kernel, it fails.
It doesn't matter which of the options I select.

Frustrated, I found a newer nfsroot.tar.gz and started over.  The
installer looks better.  It fails with the exact same error.  It
installs a pile of stuff, but it never succeeds in installing the

Frustrated, I downloaded the netinst ISO image for Linux/MIPS (version
5.0.3).  I mounted the ISO through a loopback and made it available
through Apache.  This should speed things up; I won't need to download
additional megabytes of code.

The netinst ISO image doesn't have any Release.gpg files on it.  I'm
still trying to find a way to get the installer to ignore that fact
and get on with life.  I am not succeeding.  Consequently, I have no
idea whether or not this will install the kernel.  I can't get that

Sorry if this sounds like a rant.  I've been trying for a couple
months to get this machine working (the only time I have to mess with
it is on weekends) and I still have a beautiful, blue paperweight.

Google isn't helping, much, on this quest.  So, I'm asking for assistance.

Any suggestions on what I can do to finally get this machine working?



Reply to: