[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

indigo2 seeq8003 problems


After recently upgrading to Lenny the ethernet card on my r4k based indigo2 has stopped working.  The symptoms are as if the network cable was not present - tried changing the cable and using different ports on the switch.  Nothing seems to get 'out'.  Not sure if I can turn more debugging on.  Pinging and arping'ing the machine from outside fail.

I've tried IP22 variants of linux kernel 2.6.26-2 and 2.6.29-4 (from unstable).

The network card is brought up with (from dmesg):
[17179570.240000] eth0 (): not using net_device_ops yet
[17179570.304000] eth0: SGI Seeq8003 08:00:69:08:43:b2

and when i try to do dhcp or arping I get (the machine has a static address normally):
[17180855.052000] WARNING: at /build/buildd/linux-2.6-2.6.29/debian/build/sourc)
[17180855.204000] NETDEV WATCHDOG: eth0 (): transmit timed out
[17180855.272000] Modules linked in: ipv6
[17180855.316000] Call Trace:
[17180855.348000] [<ffffffff8800b40c>] dump_stack+0x8/0x34
[17180855.412000] [<ffffffff8803910c>] warn_slowpath+0x94/0xf8
[17180855.480000] [<ffffffff8825c5d0>] dev_watchdog+0x2d8/0x308
[17180855.548000] [<ffffffff88045650>] run_timer_softirq+0x1b0/0x2d8
[17180855.620000] [<ffffffff8803fc70>] __do_softirq+0xb0/0x160
[17180855.688000] [<ffffffff8803fdb8>] do_softirq+0x98/0xa0
[17180855.752000] [<ffffffff8803ff90>] irq_exit+0x88/0x98
[17180855.812000] [<ffffffff88004424>] ret_from_irq+0x0/0x4
[17180855.876000] [<ffffffff880107b8>] cpu_idle+0x28/0x60
[17180855.960000] ---[ end trace 6a43189c51f39e20 ]---
[17180856.016000] eth0: transmit timed out, resetting

The latter error seems to be ipv6 related, not sure if I can disable ipv6 loading at boot time (not sure if it would help).

I'm able to move new deb's/sources on to it via minicom/zmodem but communications with the outside world is otherwise limited.

Anyone have any ideas/suggestions?


Reply to: