[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian with R10000 Processors

Sebastian Petruczynik wrote:

I think the problem is with the Octane (IP30) rather than the CPUs. I've got an SGI 2200 (IP27) that works just fine with Debian.

Hi Chad,
it looks like it that you made what I for a long time could not make. I have SGI Origin 2000 (IP27), but I cannot start no compiled kernel on it. I tried the patch from the page: http://www.linux-mips.org/pub/linux/mips/people/ralf/ip27/ but unfortunately it is giving no result. I also tried the newest kernels, but also without success. What version did you use? Did you modify your kernel somehow or other? What parameters did you use at starting? I want to help Debian's people, but first I must boot something on this machine.
These are logs from my tests:


And the machine... ;)


This kernels was cross-compiling on IA64 and Intel x64:

make ARCH=mips ip27_defconfig
make -j 128 ARCH=mips CROSS_COMPILE=mips-linux-gnu- vmlinux

Best regards,
Sebastian Petruczynik.

I'm currently running Etch using the standard Debian linux-source with Ralf's patches (the ones you link above). (Thiemo helped get me started with this machine, pointing me to those patches as I was a relative newcomer to mips at that point, and didn't know about the IP27 PCI issue that the patch addresses.) I've been posting recent kernels up here:


and I also just added my config to that page since you may not trust my binaries. But just installing linux-source, using ralf's patch, and my config should give you the same kernel. As for installing the system, I was having issues with tftp boots, so I used a Gentoo live CD to boot, then chrooted and bootstrapped the system. I also built the kernels directly on mips, so I'm not sure if cross compiling is your issue... maybe someone on the list might have some insight on that. (The system has 8 qty. R12000 CPUs @ 400 MHz so I tell make-kpkg to use all 8, which makes the build relatively quick, which is the reason I've never tried to cross-compile.)

As for boot parameters... from the command monitor I just type "boot -f vmlinux-<version> root=/dev/sda<root_partiton_number>". Appending root= is key. BTW, I've had no luck appending it to the kernel parameters in the kernel config (at least in earlier versions like 2.6.17, I haven't tried since 2.6.18).

Overall I'm really happy with everything - it has been over a year since I migrated the machine from IRIX, and I have never looked back. Best of luck, and let me know if you have any more questions.

Reply to: