[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

netboot problem on qube2

Hi list,

After having obtained an bigger HD for my CobaltQube2, I want to
reinstall Debian on the new HD. I set out to follow the instructions on
http://www.cyrius.com/debian/cobalt/install.html , which I used to
successfully install Sarge on the previous HD. But this time I'm not so

I installed nfs-user-server and dhcp3-server on my iBook, which is on an
internal network behind a gateway with the ip
I added the line 

/nfsroot to /etc/exports

and changed /etc/dhcp3/dhcpd.conf to contain the following:

subnet netmask {
 option domain-name-servers;
  option routers;
  option broadcast-address;
  default-lease-time 600;
  max-lease-time 7200;

# Hosts which require special configuration options can be listed in
# host statements.   If no address is specified, the address will be
# allocated dynamically (if possible), but the host-specific information
# will still come from the host declaration.

host qube {
  hardware ethernet 00:10:e0:4a:88;
 option routers;
  option root-path "/nfsroot";
  filename "default.colo";
 option host-name "qube";

When I try to netboot, /var/log/messages shows the following:
Dec 28 21:08:16 ibook dhcpd: BOOTREQUEST from 00:10:e0:00:4a:88 via eth1: BOOTP from dynamic client and no dynamic leases

while tcpdump -e -i eth1 gives me
21:23:29.439975 00:10:e0:00:4a:88 (oui Unknown) > Broadcast, ethertype IPv4 (0x0800), length 410: > BOOTP/DHCP, Request from 00:10:e0:00:4a:88 (oui Unknown), length 364

But nothing happens. The qube is connected via eth0. What am I missing here? (I tried with the Sarge installer as well, but with the same result).
I'm anxious to get this Qube up and running with Debian, but I'm stuck. Can anybody point out
what I did wrong and help me on my way? It's probaly something obvious that I missed, insights are much appreciated.


Reply to: