[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#346346: netatalk_2.0.3-3 (mips*/unstable): FTBFS: checking for gss_acquire_cred... no

>>>>> "Steve" == Steve Langasek <vorlon@debian.org> writes:

    Steve> Ok, so it seems we need -pthread -lpthreads to be fully
    Steve> correct when building a shared lib that depends on
    Steve> pthreads, as the behavior of -pthread varies by
    Steve> architecture.  Thanks.

    Steve> Brian, can you make the necessary change to the heimdal
    Steve> package, or should I prepare a patch?

I might be wrong, but my understanding after a very quick glance at
the other bug report was:

a) you can't just hard code -pthread -lpthreads as on some platforms
-pthread is correct.

b) heimdal uses libtool (from sarge currently), and libtool should do
the right thing? (perhaps sarge is not a sufficient version).

Maybe I need to read the other bug report in more detail again. I
might be confused.
Brian May <bam@debian.org>

Reply to: