[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

testing rc1 and latest daily on SGI O2

Hi all,
during a few weeks I have an SGI O2, so I am trying a d-i installation.

The system is an IP32 with an R5000 CPU running at 200mhz, 128Mb of RAM,
2x2Gb SCSI disks, CRM rev C video card, SCSI CDROM.

I selected a netboot installation and downloaded netboot-boot.img from
http://http.us.debian.org/debian/dists/testing/main/installer-mips/rc1/images/r5k-ip22/ for R5000 CPU.

The dhcp/bootp server is an i386 machine with kernel 2.6.6. On that
machine I downloaded the netboot-boot-img, saved it into /boot, and
setup dhcpd as follows:

host sgi {
        hardware ethernet 08:00:69:05:dc:0d;
        filename "/boot/netboot-boot.img";
        option root-path "/dev/ram0";

I did test the TFTP transfer with a different tftp client and it worked.
then I switched on the mips machine, started the "command monitor" and
issued the commands:

 > unsetenv netaddr
 > bootp():
 Setting $netaddr to (from server)
 Unable to execute bootp():: Invalid argument
 > bootp():/boot/netboot-boot.img root=/dev/ram0
 Setting $netaddr to (from server)
 Unable to execute bootp():/boot/netboot-boot.img: Invalid argument

but I did not manage to boot the machine. I did try even with the
netboot-boot.img from the r4k-ip22 directory.

Then I downloaded vmlinux64 version 2.6.1 from
http://www.linux-mips.org/~glaurung/ and tried it but nothing changed.

Do you have any hints on what to do or check in order to install debian
on this machine?


Reply to: