[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Missing CONFIG_FILTER in Cobalt Kernel 2.4.18...

Hash: SHA1

	The other day, I tried to set up our Gateway Microserver (Cobalt Qube 2
at heart) to use both the DHCP server (on eth0) and the DHCP client (on
eth1).  The intent was to use it as an internet gateway, much like the
Internet Connection sharing in WinXP.

	Their internet service was through Telstra Bigpond, and hence, I needed
the bpalogin utility, which I found for mipsel through APT.  This was
great -- all was well so far.  Then, I tried telling the machine to
configure eth1 via DHCP:

qube:~# dhclient eth1
qube:~# _

	As shown above, there was no errors, nothing.  It wasn't until after
much hairpulling, yelling & screaming that I happened to look in the
syslog to open this can of worms:

dhclient-2.2.x: socket: Protocol not available - make sure CONFIG_PACKET
and CONFIG_FILTER are defined in your kernel configuration!
dhclient-2.2.x: exiting.

	I did an lsmod to see what modules might have been missed, and I
noticed that af_packet was loaded, I presumed this was related to
CONFIG_PACKET, and didn't think much more of it.  However, I couldn't
see anything related to CONFIG_FILTER.

	Some time ago, I do recall trying to build my own kernel, version
2.4.20.  It built, and booted, but for some reason, the serial console
was garbled beyond use (I was barely able to restore the old kernel) and
the network interfaces, were not functional.  So me building it in I
think is out.  Is there an updated kernel image with both of these
features about?
- --
| Stuart Longland           stuartl at longlandclan.hopto.org |
| Brisbane Mesh Node: 719             http://stuartl.cjb.net/ |
| I haven't lost my mind - it's backed up on a tape somewhere |
| Griffith Student No:           Course: Bachelor/IT (Nathan) |
Version: GnuPG v1.2.2 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Reply to: