[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with Linux 2.4.20 on indy...

Hash: SHA1

	Today, I tried to update our SGI Indy (R4600SC) to run linux 2.4.20
(was running 2.4.19 -- debian version), however, after a flawless build
& install, the first boot finished up with a dirty big kernel dump.

	The kernel source for v2.4.20 was obtained via CVS from the linux-mips
repository.  I cross compilled it on my dual PIII box (running Linux
~From Scratch).

	Anyways, this is the dump (or rather, what is visible on the screen),
any ideas as to what's going on?


| Stuart Longland           stuartl at longlandclan.hopto.org |
| Brisbane Mesh Node: 719             http://stuartl.cjb.net/ |
| I haven't lost my mind - it's backed up on a tape somewhere |
| Griffith Student No:           Course: Bachelor/IT (Nathan) |

Begin Kernel Dump...
- ----------------------------<snip>---------------------------- -
|scsi0 : SGI WD93
| sending SDTR 0103013f0csync_xfer=2c  Vendor: IBM        Model:
DNES-309170        Rev: SAH0
|  Type:   Direct-Access                      ANSI SCSI revision 03
|Attached scsi disk sda at scsi0, channel 0, id 1, lun 0
|Unable to handle kernel paging request at virtual address c000c000, epc
== 8801a01c, ra == 8812f8f4
|Oops in fault.c::do_page_fault, line 205:
|$0 : 00000000 1000cc00 c000c000 88715fe0 00000020 1000cc00 08716000
|$0 : 8872be78 88704a00 00000001 00000000 00000006 8942d540 00000002
|$16: 88716000 00000000 1000cc00 00000000 88704ab8 8872be00 00000000
|$24: 00000000 88249da8                   88248000 88249ce8 8871a174
|Hi : 00000000
|Lo : 00000300
|epc  : 8801a01c    Not tainted
|Status: 1000cc02
|Cause : 00008008
|Process swapper (pid: 1, stackpage=88248000)
|Stack:    887189c0 881cf264 00000000 00000000 bfb90000 8872be78 8812f8f4
| 302f6275 73302f74 61726765 74312f6c 756e3000 a8715000 88215a6c 88704a00
| 88130054 00000000 00000080 00002000 8811eb30 bfbc0003 bfbc0007 88704a00
| 8872be78 8812fbfc 8811eca0 00000000 88116fc8 88704a00 8872be00 1110cc01
| 8872be00 88704a00 88123d1c 00000000 8872be00 8871a360 8871a3b4 88704a00
| 8871a3b4 ...
|Call Trace: [<881cf264>] [<881cf8f4>] [<88130054>] [<8811eb30>]
| [<8811eca0>] [<88116fc8>] [<88123d1c>] [<8812c7bc>] [<8812c7b4>]
| [<8812bb0c>] [<88116fc8>] [<8812bba8>] [<88124068>] [<8803ff38>]
| [<8812353c>] [<88133f20>] [<88020c28>] [<8803d4e4>] [<8803d4e4>]
| [<88134f64>] [<8806f398>] [<8802fe3c>] [<881029d0>] [<8800248c>]
| [<880067d4>] [<88002780>] [<880067c4>]
|Code: 00041023  00621824  02021024 <bc550000> 1443fffe 00441021
40016000 30a50001 34210001
Kernel panic: Attempted to kill init!
~ scsi: aborting command due to timeout: pid 7, scsi0, channel 0, id 1,
lun 0, Test Unit Ready 00 00 00 00 00
- ----------------------------<snip>---------------------------- -
I'll stop here, I've been at it for over an hour.  (phew!)  There is a
second dump beyond this point.

I've tried a few times, and so far, the dumps have been very similar, so
the fault is definately reproduceable.  Something tells me its SCSI
related.  If you need the second dump, let me know.  In the meantime, I
think I'll just restore my old kernel ;-) (somehow...)

Apologies for the line wrap.  If the line does not begin with a |, tack
it onto the end of the previous line.  I'm unable to tell Mozilla not to
wrap lines.
Version: GnuPG v1.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Reply to: